New Teams can't add Azure DevOps tab

Copper Contributor

In new Teams I can't add a new Azure DevOps tab - when I select to add a tab, select Azure DevOps I get prompted to select my organization as normal. After selecting this in a pop out window it returns to the main Teams "Add tab" window which is blank as seen below


If I switch back to "Classic Teams" this process works as normal. The screen above should have the options to select the project, whether it's a Dashboard or Kanban board etc.


Is this the best place to report this as a bug?

8 Replies

@ryancairnstm that is strange. In several tenants it works as expected. Are you the only one having this issue?

@paul keijzers Also happening in our tenant as well.

@paul keijzers I am also seeing this issue.

I had a similar issue with another App and pinning to the new Teams. I had to reset New Teams through Windows using Settings-Apps-Teams-Reset.
There are instruction from Microsoft, but I cannot find the URL.
Once I reset it, all of our Tenant apps were pinned, and I was able to pin new apps
I tried resetting and it didn't resolve the issue. I can pin other apps ok - the issue is only with Azure DevOps. After selecting the organization it doesn't load the window properly to select the project / team / board,
The issue now seems resolved. I have tested in multiple teams, public and private channels and working as expected. Excellent.



Can u share the solution, we are having the same issues.


@nlsz1 sorry - no solution. I didn't do anything, it just started working after months of trying. I assumed it was an update that fixed it.