SOLVED

Microsoft Teams Desktop on Mac Stuck in Login Loop

New Contributor

I recently changed from one MS Office 365 email/organization to another.  I've removed the "old" Office 365 account from everywhere I can find on my Mac, but when I launch Microsoft Teams - every time - it asks me to login with my "old" email address.  When I click sign in under a different account, it goes through - but Microsoft Teams just gets stuck in the same loop.  How can I fix this so I can use the desktop app with my new email/organization?

57 Replies
Referred following link and the issue seems to resolved for good for me.
https://www.uvm.edu/it/kb/article/clearing-teams-cache/

Its a 5 step process:
1. Fully close Microsoft Teams.
2. Copy and paste the following into the Go to Folder box, then click Go:
~/Library/Application Support/Microsoft
3. Right click the Teams folder, then click Move to Trash.
4. Using Spotlight Search (accessed by clicking the magnifying glass on the macOS menu bar), enter “Keychain” and select Keychain Access. Search for Microsoft Teams keys in keychain. Within Keychain, search for “Microsoft Teams” to find the Microsoft Teams Identities Cache entry. Right (two finger) click this item and select the delete option, then close the Keychain Access app.
5. Relaunch Microsoft Teams. You should now be prompted to sign back into Teams.

@ARBattase I tried your steps, in keychains nothing comes up.... anything that said microsoft I deleted regardless, closed the keychain and reopened, no change in teams. Still my personal email is there, and the button "sign in with different account" is there but nothing happens when i click it. 

 

 

@ARBattase I have also done these steps many times and still have the issue.  I even searched for all files with Teams/teams in it and removed them.  There is no entry in the keychain.

 

I have 2 Mac's.  I finally got 1 to come around, but the second did not.  

I JUST got mine to let me sign in, but now I'm getting a message with my work email saying
"That Microsoft account doesn't exist. Enter a different account or get a new one". which is garbage since I can literally log in online to the web version of teams with THAT email.

I got this tip from a colleague who had this issue...he got this from another post and it worked for me.

 

"I found a tip to install this version for MacOS because this error occur when we change the password in a account MS365 and the validator Server is a ADFS not Azure.

 

https://statics.teams.cdn.office.net/production-osx/1.3.00.28778/Teams_osx.pkg

 

It an old version but when enter on temas choose the option update without logout."

 

@Jeff_at_K2 installing an older version of Teams would solve the issue. 

I had the same symptoms but with a personal account I regularly use with Teams. I have the habit to switch back and forth personal and professional accounts, as both use different email addresses. Professional account works fine, but personal account gives a blank popup and never loads further. If I close the blank popup manually, Teams complains about an error, and gives Error code 1:403 at the bottom of the screen.

 

@ARBattaseI did just that:

  1. removed everything that was coming up with EasyFind using the "Teams" keyword, including logs and (except one folder related to third-party content on "how best to use Teams" (ironic) and the .pkg installer itself).
  2. Using AppCleaner to remove the executable itself (can't do that from EasyFind).
  3. Emptying the trash can from the command line.
  4. Checking there is nothing in the Keychain Access.
  5. Downloaded & installed a previous version of Teams as per @computerninja

Result:

Logging in with the institutional account works just fine.

Trying to switch to a personal account using the menu opens up a web page, but keeps on loading, then fails.

I log out manually, takes a while, then I try once again from the desktop application, and now I am presented with the choice to either Download the desktop version (which I already have open and running at this point) or use the Web version (See attached).

If I click the first button, it starts downloading the client. If I click the second link, it correctly starts the Web version, but never acknowledges the installed desktop application, which is rather annoying since I use it mostly for video calls, one function that isn't available from a Web browser.

Trying to switch the other way by logging out using the Teams menu gives the first login screen. Entering my personal login gives the white popup and never loads further.

 

I know my personal account has no issue: it logs in just fine on iOS Teams, on Teams for Windows, on Teams for the Web.

 

A full reinstall won't fix it…

For anyone else with this issue, this worked for me and was super quick:

  1. Stop Teams (even better, reboot your Mac!)
  2. Open the `terminal` application on your Mac (click Launchpad then type term, hit Enter)
  3. Change to the Teams directory - e.g. cd ~/Library/Application\ Support/Microsoft/Teams
  4. To find files that mention your 'bad' email address (note there is a dot at the end of this command!): grep -r 'mypersonalemail@eghotmail.com' .
  5. For me, this gave desktop-config.json and storage.json
  6. Run rm desktop-config.json and then rm storage.json

Now when I restarted Teams, it asked me which of the two accounts on my Mac I wanted to use - my personal one or my business one.

Anyone able to solve ?? tried all the suggestion, but still not able to solve.

@Eric_Siew That was happening to me. Have you tried logging in with another Mac user account? My issue was that I had Edge installed on my Mac and after that, I just can’t signed in on my macbook nor switched account. I wiped out my Mac system twice only to figure out it was Edge and now, I have 3 Mac accounts. 1 is the admin, 1 for home personal and another one for work so I pretty much separate the Teams accounts(personal and work) with 2 Mac accounts. 

@ARBattase Your proposed solution works perfectly for me. :ok_hand: Thanks!

This finally worked for me, many thanks@Peter Wake 

It's very helpful
It's work for me
Thank you so muchhhhhh

@computerninja 

 

Thank you so much! This worked for me! I did uninstall the old version with AppCleaner and deleted the related Keychain files. I then downloaded the old version and was then able to log in with my work account.

 

After that, I then reinstalled the newer version, and it was still connected to my work account. Very grateful!

Thank you so much for this. This was the only way to solve the issue on my Mac Mini M1!
Thanks, that worked for me
Worked perfectly.. I would expect an uninstall option to tidy this up completely.

Thanks, this worked for me.

 

What through me off was that when I used file explorer to go to Library, I couldn't find any mention of Microsoft or Teams folders as they were totally hidden, yet when I used your method of "Go to folder" and paste the path, it comes up with the Microsoft folder and I can see the Teams folder.

 

I have used this quick fix on two machines stuck in the login loop and both worked perfectly

 

@ARBattase 

Deleting this folder helped. Reinstalling and stuff did nothing to this issue