Microsoft Teams Desktop on Mac Stuck in Login Loop

Copper Contributor

I recently changed from one MS Office 365 email/organization to another.  I've removed the "old" Office 365 account from everywhere I can find on my Mac, but when I launch Microsoft Teams - every time - it asks me to login with my "old" email address.  When I click sign in under a different account, it goes through - but Microsoft Teams just gets stuck in the same loop.  How can I fix this so I can use the desktop app with my new email/organization?

63 Replies
Try removing the password from the keychain on the Mac. This may solve it

Let me know how it goes

Best, Chris

@Christopher Hoard 

That still won't do it...same login loop.  Thank you for the suggestion.

Ok, try deleting the keychain itself. If it still doesn’t work uninstall and reinstall Teams

Let me know how it goes

Best, Chris

I'm encountering the same issue and redownloading Microsoft Teams didn't help the issue...@Christopher Hoard 

@Christopher Hoard 


This didn't work either - and I removed and reinstalled Teams and no luck.

best response confirmed by Therese_Solimeno (Moderator)


I’ve got this login loop after I logged in with me private MS account in Teams. I stucken in a login loop when I tried to log with my company account in Teams. Close your Teams application and go to $HOME//Library/Application Support/Microsoft/Teams in files browser and delete/move the Teams folder to Teams_old for example.


Start your Teams application, the Teams folder will created and the Login window appears.


For me it works, when I delete the $HOME//Library/Application Support/Microsoft/Teams folder after I was logged in with me private MS account.



I would be interested to see if this fixes it :D Fingers crossed :D

Best, Chris

@Christopher Hoard Sure did for me. I kept getting annoyed for hours, after I had altered/deleted the folder but not the aforementioned folder… Thanks heaps, Heiko1410!

Same problems after update my MACOSX and the teams software.


MacOSX: 10.15.6

Teams SW Version:


Error Message after login with business account:

Teams: desktop-9ca18d2a-9ef3-41f1-bbaa-db42cb327a67

Fehlercode – 1:403
My solution to delete  $HOME//Library/Application Support/Microsoft/Teams folder don't work in the software version above. But it's interesting my private MS account work and the business account stuck in login loop. Deinstall with AppCleaner and install the Teams_osx.pkg don't work. Any clue how to fix this ??

@atunellRTG I got same issue that Teams on Mac stuck in login loop. It turns out the root cause is my certification - I reinstalled my mac without changing my computer name. After that, I use my org's MDM tool to enroll my Mac but failed but I didn't noticed that. So I keep got that login loop issue.


For my case, the solution is simple - I removed my Mac registered in MDM portal with old computer name. Rename the computer and re-enroll the Mac. Once done, I can login Teams without any issues then.


Hope it helps for your case.

@atunellRTG Clearing all Teams items from keychain and then restarting the Mac fixed for me, after restart it prompted with the correct login box! 

For all those who weren't able to login using the above recommendations, I followed the below steps and worked for me:


1 - I signed in to my personal Microsoft account using teams for iOS

2 - I restarted teams from my Mac desktop app 

3 - Then it auto logged in without getting stuck in the login loop 


Hope it works for you :) 

Don't delete your keychain unless you have a backup.

The library folder is hidden by default. For those who need help: go to the Home folder, right click anywhere in the folder, and choose "Show View Options", then "Show Library Folder".  


same. Ive been at this for 5 hours

I have deleted all of the cache, deleted the application, deleted all they keychains and the account is still stuck in the loop.  I cannot log in.  I finally got it working on 1 mac but haven't on the second mac.  There is a serious flaw here.



Spent two hours the other day with a user's MBP trying to unravel this. Finally got it working by deleting every single "teams" file and folder on the machine (searching both root and user's library with EasyFind), then deleting and remaking her Microsoft account and re-activating her apps and installing teams (fortunately we host our own email server). I am not positive which step finally did it, as she needed her computer back and in the end I was trying everything under the sun in rapid succession.