Microsoft Lists - There was a problem reaching this app

Frequent Contributor

I've created lists in a Team and added them to a tab. I tried to share those lists with another team - adding Direct Access permissions and then adding them as tabs in the other team. That wasn't completely successful - users got a messages "There was a problem reaching this app". I then instead added the users as members to the original hosting team of the lists. They can now access those lists in the original team.

Now I'm getting the message "There was a problem reaching this app" in the original hosting team when attempting to access the list tab. I'm an owner of the team and I have created the lists. I've tried everything from signing out, quitting Teams etc. to no avail. I have not yet removed the tab and added it again (since it is currently being used) and I have not yet rebooted my computer. It is quite frustrating when I'm trying to convince others that this is the way to go.


I have now rebooted and the problem persists. I must add that I have been able to successfully use the Lists tab in the past in this particular team. I can still access the lists in the browser with the Microsoft Lists browser app, however, it does not work in the Teams tab for me anymore. Others can use it but I can't.


The problem is with the Lists app in Teams (my client). I cannot add a list to a tab anymore. I can access the Lists tab in the Teams Web app. The solution might be to reinstall Teams.

11 Replies
best response confirmed by Marius Pretorius (Frequent Contributor)

So the solution was to reinstall Teams. I installed it over the existing one (i.e. without uninstalling it first). After that the Lists tab in Teams was working. The clue was that it was working for everybody else except for me (after it had previously worked).

@Marius Pretorius 

Hi, I had the same problem.

I created a lists tab in the team from an existing list, the title of the tab loads correctly but the content area stills loading the list for a while and finally appears the error "There was a problem reaching this app".

But in my case that error happens to all users of the team, and also in the Teams app and in the browser.


Any idea to solve this error?



@HugoPires Not sure what you have checked all, but the obvious place to start is with permissions. The original list needs to belong to the same team (SharePoint Group) as where you are attempting to add it as a tab. Else all the users there need to belong to the other team (SharePoint Group) as well, where the list originates from. 

Most likely, you already checked the above. More than that I cannot say. Perhaps someone else will chime in?

@HugoPires I have the same issue as you. Permissions are definitely not the problem, as this is a list we all use as a team regularly. Does anyone else have ideas of what might be causing this issue?

@forcedLightning@HugoPires@Marius Pretorius  

I had the same issue, what I end up doing was adding the tab but selecting the SharePoint instead of List; it worked, and it displays the same as the List, I think this is a bug in Teams.


Hope it works for you too.

Having the same problem. I'm considering reinstalling, but want to make sure I won't lose my Groups or Chats. I tried creating my list on the web app, but it won't import directly or with the Sharepoint link.
By uninstalling Teams and reinstalling it, you don't lose anything. It is simply a client. Not saying that in your case it will solve your problem - but it is worth a try.

@Marius Pretorius 

Thank you Marius. The re-install did not solve the problem, but figure out it may be a permissions problem.

Yes, as I described in my main post - permissions is the first thing to look at. In my case, it worked initially and then stopped working. It was also working for others, but not for me anymore. Reinstalling Teams resolved that issue

@Marius Pretorius 


I have the same/similar issue.  Butmy problem is that Lists app on my desktop keeps trying to open a list from another 365 account.  I have other 365 domains I handle and want to be able to swap between them. Like in OneNote. 

I can't find a way to open another list, or close the one I'm in.


Had this issue today. Instead of reinstalling Teams, I think the easier way is to clear the Teams Cache - worked for me. To clear the Teams cache, e.g. refer to Clearing the Cache for Microsoft Teams (Windows) - ANR Information Technology (