Join or create a team not working

Copper Contributor

I am trying to join a team.  I am already guest of it but for some reason, it disappears from my list and I need to rejoin each day I am logged in.


Normally, I would click through "Join or create a team", search for the name and then it appears and I can join for it to be added to my list.  I am trying to click on the Join or create a team and nothing is coming up.

I have tried in the Windows app (using windows 11) and on the web.  I've logged out of the windows app and it is still not working.


Below is a picture of what comes up when I click on the "Join or create a team".  I tried to search the team name but nothing comes up.


When I am an owner of the team, it does not disappear from my list, only when I am a guest.


I have other teams appearing on my list and I can access those with no issues.


Teams eorro.jpg

6 Replies
Are you trying to add yourself as guest or as owner?
Is it the whole team? Is it a Shared Channel? is it the preview version of teams? A bit more technical info would be handy.
As I said, I already a member of the team. The whole team disappears from my team list so I need to go and search for it and join it again at the start of each day. It only happens to the teams where I am a guest and not an owner. In the Member settings, my contact is already in there when I go back in. I can't upgrade myself to be an owner. I have asked to be added but it hasn't been actioned.

Regardless, the issue is I now cannot "join or create a team" for any team but using the capability at the bottom of the program. The picture I provided is what comes up when I click to go through. It will not let me search and is not functioning. It is not to do with the individual team but rather the app itself.
Hi Thanks for your message it is unclear if you are a member or a guest of the team. There is a major difference there. So are you member(same o365 email adres and domain) or guest(external emailadress different domain)
We are also having this same issue, just reported to us today. Users are presented with the same code looking entries vs. the original Create Team and Join Team option.
My account is on the same domain, not external. But the issues isn't an individual team and not being able to join it. I cannot search for a team in the first place. Nothing is coming up to search for the team I am looking for to even request to join the team. That is the issue, not joining the team once I find it, I can't find it in the first place.
I would recommend to create a ticket for this.