Microsoft Security Tech Accelerator
Dec 06 2023, 07:00 AM - 12:00 PM (PST)
Microsoft Tech Community

Defender for Identity Sensor throwing seemingly internal errors

Copper Contributor

Hey folks,


today I installed MDI sensors on some Windows Server 2022 DCs with .NET 4.8 installed. All of the setups ran just fine, however two of the DCs threw the following errors.


DirectoryServicesClient System.MissingMethodException: Method not found: 'System.Threading.Tasks.Task'


DirectoryServicesResolver System.MissingMethodException: Method not found: 'Void Microsoft.Tri.Common.UpdateDirectoryServicesClientAccountIdsRequest..ctor


Both of those errors made me scratch my head so hard my hair fell out. Maybe some of you guys have had this issue before.

BR Felix

8 Replies

@felixbrandsva Did the sensor worked before in previous versions? If so, which version started to break with missing method?

@Eli Ofek it is a fresh installation on all DCs. Never had MDI running on them.
I am guessing you have a weird assembly deployed in your gac that collides with the sensor expectation.
I suggest to open a support ticket.
Make a list of 3rd party software installed on this machine.
Try to open an elevated cmd on the failing machine and run this command:
dir /S /B %windir%\Microsoft.NET\assembly | findstr ValueTuple

Please paste the output here. it might help to make some progress.

Hi @Eli Ofek, I ran the suggested command on one of the malfunctioning DCs and compared it to a well-functioning one.

Output malfunctioning DC





Output well-functioning DC





best response confirmed by felixbrandsva (Copper Contributor)
This is what I suspected.
Something installed on the failing one the assembly with this specific version:
this shouldn't be there.
if you uninstall this version from GAC the sensor should work.
The problem is that I don't know which app decided to install it there and it might break if you remove it.
What 3rd party apps do you have there which are not on the working machine ?

See here for instructions how to correctly uninstall this assembly for this specific version (the other one should remain there)
Hi @Eli Ofek, let me try to find out which application installed the assembly. I will keep you updated!
UPDATE: @Eli_Ofek I have not found the respective application using the ValueTuple.dll of version However I renamed the .dll-File and no application is showing any issues. I will keep track of the applications. Thanks for helping me out on this one! Appreciate it!