MS Bookings doesn't save after editing a Service

Copper Contributor

We use Bookings a lot and I have to change our Services quite often.  We are having an issue were when we make modifications to our one of our Service (availability options, etc) we can't save after entering our modification in the Edit Service window.  We click on Save Changes an NOTHING happens. No error message, just nothing.

When it works, you click on Save Changes the windows closes and the modifications are made to the Service, but 95% of the time we click on Save Changes and the Edit Service window stays open and the modifications are not saved.  We tried using different browsers, account (all with admin) and we can't fix it.  It becomes really hard to make modifications.  How can we fix that issue?  Thx.

17 Replies

@cprudhom Getting the same exact behavior as you, Anybody found a solution or aware if it's a bug with Microsoft. tks :)

Same problem here.
Do you see any error on the screen or in the network logs when this happens?
Are you an administrator on this Bookings calendar? Only admins can edit the service settings, if you are admin and if it is still failing, can you please capture the network logs (HAR) and DM me?

@Babu_Alagarsamy  Yes I am full admin on all our booking page and issue occur on all our booking page, We also try with other admin and we all have the same issue. Issue occur when modify any setting on any page, safe just does not happen. I even try to change permission on some account it save but never change after you refresh the page so change do not happen.

Same issue. I am an administrator and can't add staff or services to booking calendars.

For services, I can click "Save changes" all day long and nothing happens. For staff, it seems to save for a moment, but then goes back to tell me "There are no staff added/Add new staff."

I've tried Firefox/Edge/Chrome, removing cache/cookies, adding a new booking page and also copying a working booking page. On the latter, everything copies but I can't edit the service, delete the (copied over) service, or create a new service. Microsoft, can you help us out here?
Same issue on our tenant. Administrator of the page, able to make changes, yet when clicking "Save Changes" nothing happens. Currently not able to unpublish a service and make changes to another service within multiple browsers.
can one of you please DM me the network logs (HAR) collected when you load the services page -> edit -> save?
I am having the same issue, Bookings is unusable right now for me. Can't save an existing service or a new service... How does this get fixed or do I need to find another service to use now?
I am also having the same issue, but in Staff. When trying to add a staff, nothing happen. I tried to delete a staff and nothing happen either. Any solution on this please?

We have an ongoing case with Microsoft since 21 of Februari. The Bookings team and the product group are involved. Unfortunately they haven't found a solution yet.
Found on another thread: Open Bookings from Teams, saving changes to an existing Bookings Service works!
Thank you, it is indeed working from Microsoft Teams!


I have now received info from MS that they have resolved this issue. They didn't explain how or what was the root cause.

I have tested and now I can save changes.

Thank you for letting me know. I hope it fixes it for good.
Unfortunately, in my case I still have the same problem form time to time. Its not constant, but it happens regularly that I cant make changes because it doesnt save and close the Edit