Outlook (365) Need Password - Issue

Copper Contributor



We are using E3, outlook 365 in our company. Some of our users' outlook stop sync with exchange and ask for password, as shown in below image:


Password Issue - Copy.JPG


to fix the issue, I clear entries in Credential Manager, Delete Temporary Files, unchecked "Use Cached Exchange mode", restart system and check this again.


but after some couple of days, outlook again stop sync and ask for password.


I'll appreciate for any possible support to fix this issue permanently.



129 Replies
This worked for me, thank you!

@Muhammad Ali Khan 

I will solve your problem in 2 steps. Please do not forget to like this solution. 

1. Outlook ; click "File" then "Office Account."

2.  Then click "Sign out" and first sing out completely, then sign in again, from the same path.


You are all set. Just close Outlook and restart. Now you start to smile and start to thank me.




Thanks.  We've tried this and it doesn't work for us.

@Emre_Uchar   That has not worked long-term for me.  Within a couple of days, the issue returns.





Thanks, like others I have been hopeful with the confidence of posts such as yours.  Sadly, it works for a bit and then we are back.  For us, the issue won't appear for as long as 3 weeks and then one morning, the user comes in and Outlook is not connecting to exchange - "Need Password" at the bottom.  They leave their systems on all the time so all I have to do is reboot and Outlook is happy again.  Oddly, if they turn their systems off each night, the problem will still appear on the next random day.  To me, that indicates it is the system reaching out to Exchange and encountering an error.  Once the error is created, the reboot clears it somehow and the system is good... until it's not.  Thankfully this client is replacing these "older" (6 yrs old - not Win 11 compatible) units in the new year.  I've shared this thread with them so they know I'm on the job - lol.  

@Muhammad Ali Khan
Dear Microsoft,

Same problem here, since I clicked on use the "Try the new Outlook" feature 5 weeks ago and switching back. Outlook keeps nagging every 5 min or less to fill out my password, if I click on the Need Password status field in Outlook it signs in automatically. There is a password field visible at the moment it asks for a password and if filled out it connects as well.
Have tried reinstalling Office several times, clearing credentials, adding registry keys and clearing the cache. Removing old folders and cached files.
When reinstalled it takes a couple of hours when starting to ask for my password  again.

Gr. Harm

@Muhammad Ali Khan 

Same issue here for over a year now. With open Microsoft tickets have tried all answers given for registry keys with no resolution. We have found recently that restarting the office click-to-run svc will immediately fix the issue without a computer restart, but the error will reoccur shortly after. Application event log records the following C2R error log. Are there any fixes for this as we have already reimaged and deployed new machines to impacted users.



@Aaron_Rd - Thanks for that tip about restarting the service.  I have had this issue for over three years and have tried just about every suggestion folks have come up with. I have been dismayed that Microsoft seems to have done nothing to resolve this.  We simply have to restart our two workstations with the problem every 36 hours or so.  But so often, the issue comes up right when you really need to get something done and now have to close everything and reboot.  Being able to restart the click-to-run service would definitely be easier.  I will try it out.

@BEBaker - Just a follow-up to @Aaron_Rd.  Restarting the Click-to-Run service works great.  It is a significant improvement versus restarting the machine.  It is a bit frustrating that after a number of years, MS has not been able to resolve this one.  If restarting this service solves the problem (albeit temporarily), I would hope that it might help narrow down the source of the problem and possibly lead to a permanent solution.

Restarting the Click-to-Run service does not work for us.