Custom DNS records missing

Iron Contributor

On one of our client tenants we've just noticed that all our custom DNS records have dissappeared. 


Has anyone else experienced this? 


Is there a way to track if this was a use who did this or if this is some kind of system problem? 

8 Replies

This has just happened again. I'm creating a service request with Microsoft again as this is urgent, but I wanted to flag this up here again because I find it hard to believe that we're the only ones seeing this! 

We are a Microsoft partner and have seen this happen several times for multiple customers. I believe it is related to running the setup wizard again where it wipes out and resets all DNS records. It should definitely KEEP any custom records during this process. I am working on the issue again this morning. With the last customer, we moved them back to GoDaddy DNS hosting so it won't happen again. I also noticed you cannot add any custom SRV records to the 365 DNS. 


Just be careful clicking the "DNS Management" option when working with a domain. While it seems like this is where you should go to manage DNS, it takes you back through the setup wizard for a domain that is already in the "Setup Complete" status. 

Just for reference we went through all the possibilities and the setup wizard wasn't the problem. According to Microsoft they resolved this issue but it proved not to be the case with us. It was also never publicly noted so there's record of what was wrong or what was fixed. 

This has happend to one of our clients as well.. sometime this last week.

Happened to me this week also. Wednesday, 11am, all records disappeared. Funny thing was the tech on the other end of the phone could not see the new records as was adding back and after about the 4th new custom records, the system would delete all again when I added a 5th record.


Only way to make it work was to re-run the dns setup wizard - as done when you first set up your account.


The thing that upsets me the most is that MS claims this is not possible - as if it has never happened before and tried to pin it on me. I was in the car driving when it happened and I am the only admin for our organisation.


@Dion Phillips This just happened to me.  I opened a support ticket in a panic.  However, here is what I did.  We used the old Admin experience, then went through the wizard again.  Then the custom DNS records became visible again.  When we first visited the domain config using the new admin experience is said that no Office 365 features were assigned to the domain. That is pretty interesting as this is the DEFAULT domain.  Wow.  Now, if I visit the new admin experience it prompts me to run the wizard again, which I am not going to do.  Using the old admin experience lets me both view and edit the custom records, and we have a lot in there.   Even though I just opened the ticket and saw this, they closed the ticket.  I am not sure how to proceed with my Ticket #20035523.   Can someone else from Microsoft pipe in here? @Pernille-Eskebo 

@Jacques van der Hoven 


Just had the same problem on a customers tenant. 


Go to "Manage DNS" > choose "Set up my online services for me". Click "Continue" until that you see "Add the records for your website" and then you should see all your records again. Click "Continue" again and finish the setup guide and the records should be back. 


I guess it's a bugg that the records disappears and that the records is still working however you just can't see them... But I can't tell. 


Hopefully this helps someone.

@AzeoMartin you saved me a whole load of stress last night, thank you. This worked perfectly to restore my missing custom records. I'm pretty sure this was caused by partially running the setup wizard to check a couple of things the day before!