Archive On-prem not available in Hybrid environment

Iron Contributor

Archive was enabled for on-prem mailbox from the local Exchange server in Exchange hybrid deployment. Exchange Online plan 2 license is assigned to the users. The archive folder is visible in OWA (on-prem), but there is no access. Error message: "The archive does not seem to be available. Please try again later".

The status of the archive is "Active" in Exchange Online.

I ran the following command in PowerShell:

Test-ArchiveConnectivity -UserSMTP


Sign in to mailbox not possible.

Error: An Autodiscover request could not be created for an incorrectly configured Office 365 mailbox.

1 Reply
it appears that there may be an issue with the Autodiscover service not being configured correctly for your Office 365 mailbox.

To troubleshoot this issue, you can try the following steps:

Check the Autodiscover configuration settings: Verify that the Autodiscover service is configured correctly for your mailbox. You can use the Test-OutlookWebServices cmdlet in PowerShell to check if Autodiscover is functioning correctly.

Verify the credentials: Ensure that you have the correct credentials and permissions to access the archive folder. Make sure that your account has the Exchange Online Plan 2 license assigned.

Check the connectivity: Ensure that you have a stable and reliable internet connection to access the archive folder. If you are using a VPN, try disconnecting from it and see if that resolves the issue.

Contact Microsoft Support: If you have tried the above steps and still can't access the archive folder, you can reach out to Microsoft Support for further assistance.

I hope this helps you resolve the issue! If you have any other questions or concerns, please let me know.