Update Rollup 5 for Exchange 2007 SP1 (announced a few days ago) has been released. The rollup is available on the Download Center here: http://www.microsoft.com/downloads/details.aspx?FamilyId=652ED33A-11A1-459C-8FFE-90B9CBFE7903&displa... The rollup will go live on Microsoft Update in 2-3 weeks from now (will be announced here). Localized versions for all supported languages are now available on Download Center. KB 953467 has more details about this release and the included fixes. We specifically want to call out two fixes related to the overall installation experience: 1) Service startup issue described in KB 944752 and a previous blog post.

  • The rollup installer will now make the required modifications to the config files, even create new config files if not found. If customers have already modified the config files and have a generatePublisherEvidence setting, it will be left intact. Note that you still need the right version of .NET (see KB 944752) for the fix to take effect.
  • Uninstalling the rollup will not rollback the addition of generatePublisherEvidence to config files.
2) Blank OWA logon page after installation of rollups 3 and 4, if you have modified logon.aspx file
  • The rollup installer will now overwrite any OWA script files if required to ensure proper operation of OWA. You will need to redo any customization after installation of the rollup.
- Nino Bilic

Not applicable
"The rollup installer will now overwrite any OWA script files..." I'll test this next week in my lab but, does this include replacing any customized login pages?
Not applicable
Will all rollup's be released to MS Download 2-3 weeks before MS Update?  I am asking because of the issue with rollup 4.  I would prefer rollup's were not automatically installed by MS update, but having the patch released on MS Download weeks before MS update is at least a step in the right direction.
Not applicable
So I am not sure why this keeps happening but when I install an RU it goes through the install and at the end it says it ended prematurely. After a reboot Programs reports that the update is installed successfully and the dll's i have spot checked have the new file versions. This same behavior happened in RU 4 also. Is this happening to anyone else?
Not applicable
RE: "Rollup installer will now overwrite any OWA script files"


The OWA ASPX files are tied to the companion OWA DLL file. If the OWA DLL file needs to be updated in the system for any reason, all the OWA ASPX files will also be overwritten to ensure proper operation of OWA.

If your Outlook Web Access (OWA) customization only changes the graphics on the logon page as described in http://technet.microsoft.com/en-us/library/bb201700.aspx, you should be fine. If you have edited the logon.aspx file or any other OWA file in the system, it will get overwritten.

As a best practice I would always recommend a backup of any OWA customizations made to the server.
Not applicable
Same issue as rob gooch - exchange setup ends prematurely. NO errors in the event logs and NO files created in c:exchangesetuplogs so I'm not sure what else to look for.
Not applicable
Andy and Rob,

If you had a failed install (that "ended prematurely" - please open a support case so we can figure what is going on. We have not seen this yet that I am aware of...
Not applicable
Korbyn said:
I've applied RU5 to an 2 CAS/HT, 1 SCC Mbx Cluster environment, and am still having the issue with OAB being unable to generate on shared disk.  I just get the 9334 and 9109 errors and had to reinstate Mike Shen's fix in http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3686285&SiteID=17

Anyone else have the same experience?  I did repoint the oabdropfolder location back the shared drive location and reset the permissions before giving up.  The folder icon whould change, but the system just could not create the subfolder with the oab files.
Not applicable
I have already had a case opened about this when I was dealing with the OWAappPool crashing due to entourage and noted this install failure on RU4 with my engineer. Honestly right now unless I see adverse effects I don't have time to open another case and waste more premiere hours on the phone with someone from India. If you would like my msi installer logs feel free to contact me at dasgooch@gmail.com
Not applicable
I hate to sound like a broken record but I see not specific mention of fixing the Entourage issue and app pool crashing. Is this being or has it been addressed as we are now 3 rollups out of date on our production server due to this issue.
Not applicable
Installed it today across our entire EX07SP1(RU1) environment. No problems; thanks ladies! :)
Not applicable
Thank you very Much! Its Great !
I used it on a virtual enviroment and works just fine! Thank you!
Not applicable
I'm having a issue with the amount of Recipients being displayed on the Recipients Container, 1000 is now to many... on one server I can only display 994, another it's 971.  The AD MaxPageSize is currently set to 1000.  We've changed it to 10000, no difference.

The error is:  Active Directory rejected paged search cookie because a cookie handle was discarded by a Domain Controller or a different LDAP connection was used on subsequent page retrieval. Paged search needs to be restarted and will succeed

This appears to have been an issue with OWA lite and was resolved in RU1, but I've seen this in the EMC a couple of times.  I seem to have hit this on RU3 and RU5, I didn't experience the problem on RU4.

Not applicable
Further info, breaking the recepients command down, it seems to barf on "MailContact" types, of which, this company seems to have over 28,000 of them, but still, I should experience this error when just trying to display 1000 or 2000 objects.  I'm guessing perhaps one of them is corrupt or something, but I didn't have this problem last week on RU4, and uninstalling is such a pain...
Not applicable
Sorry guys, would seem that this sites Patching process is having some problems, appears to be an issue when MS08-003 is installed and hasn't been updated with MS08-035.  Will have to wait for the next patching/reboot cycle to hopefully resolve.
Not applicable

After roolup 5 install I'm getting this error on the CAS server when trying to access the web site. I have open a support case and after 6 hours on the phone decided to roll back to rollup 4. Any idea what could be causing this?



User host address: xx


Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException

Exception message: Object reference not set to an instance of an object.

Call stack



Microsoft.Exchange.Clients.Owa.Core.Global.ExecuteApplicationStart(Object sender, EventArgs e)

Inner Exception

Exception type: System.NullReferenceException

Exception message: Object reference not set to an instance of an object.

Call stack

Microsoft.Exchange.Clients.Owa.Core.Configuration.CheckAllLegacyPublicFolders(ADSystemConfigurationSession session, ADObjectId[] pfdbIds)

Microsoft.Exchange.Clients.Owa.Core.Configuration..ctor(ADSystemConfigurationSession session, String virtualDirectory, String webSiteName, ADObjectId distinguishedName, Boolean isPhoneticSupportEnabled)




Event Type: Error

Event Source: MSExchange OWA

Event Category: ADNotifications

Event ID: 65

Date: 12/3/2008

Time: 3:00:46 AM

User: N/A

Computer: servername


An error occurred while the Outlook Web Access configuration settings were being loaded. Virtual directory: "owa". Web site: "Default Web Site".

Error message:

"Object reference not set to an instance of an object."

For more information, see Help and Support Center at


Not applicable
Throug Windows update it still unavailable. Too many problems ?
Not applicable

before installing Update Rollup 5 i have two questions.

1) Do i still need the same account the Exchange Server 2007 was installed with?

2) Is the ngen process now high priority or do i still need a considerable time for the installation?

Thanks for the clarification.
Not applicable

There are 2 "erros" you shoould know about with this.

1) Once again the update is not updating the build number either in the console or in the registry

2) If you install Exchange 2007 SP1 and then the latest update rollup (rollup 5) your machine will still detect that it needs update riollup 4 from the windows update site (possibly because 5 isnt on there) if you are running Windows 2008 (I am told it doesnt do this for Windows 2003)

The second ones quite serious as the update may be applied automatically which could give you a very bad time with code

I have logged a call with MS to see what they can do - if anyone else is seeing this perhaps they can leave a comment here ?


Not applicable
In our environment the config files where not updated and the KB mentions that the problem could still occur?

Tonino Bruno
Not applicable
I'm trying to install Exchange 2007 SP1 Rollup #5 onto an existing EX2k7 SP1 64-bit Enterprise installation.

When I run the .MSP, it spends a good while "computing space requirements," before prompting me to begin the install and accept the license terms.  Then the "Installing..." window gets busy for about 10 minutes.

Unfortunately, the end result is a blue, white and gray dialog - a normal .MSP screen - which says...

"Setup Wizard for Update Rollup 5 for Exchange Server 2007 Service Pack 1 ended prematurely because of an error.  Your system has not been modified.  To install this program at a later time, please run the installation again."

To my eyes, there's nothing conclusive in the logs which are tossed into C:ExchangeSetupLogs .  (ExchangeSetup.txt has long been missing from that folder.)

Curiously, Rollup 5 appears in Add/Remove programs and can be removed without incident.

Going off a TechNet thread which involves the same symptoms, I've set the TEMP and TMP system environmental variables so that they point at c:temp, and I've put very generic permissions on that folder.

Looking for advice and sympathy :)  Thank you.
Not applicable
I wanted to add that the same problem prevented me from installing RU4.  Reference Experts-Exchange question ID 23865589.  I'm a small business and can't risk a PSS call on spec - if you can offer any advice here it would be very much appreciated.  Thanks.
Not applicable
Made it go.  Finally.

.NET Runtime Optimization Service v2.0.50727_X86
.NET Runtime Optimization Service v2.0.50727_X64

For as long as I can remember, I've disabled these services.  If I want the optimizer to kick off I'll manually enable the service.

This morning, on a hunch, I set the services to manual and started them.  RU5 completed sucessfully.
Not applicable
Tim, Glad that you figured it out. Maybe we can modify the KB article or setup a BPA check for that to alert the customer.

Tonino, the config files should be updated unless you have them locked down for ready only or such. Is this still a problem?

Philf, The rollups do not update the version stored on the server object at the Active Directory and does not update a specific version number stored on the machine. It is a product limitation. You can find sever enhanced versions of the get-exchangeserver which will also check for http://blogs.flaphead.dns2go.com/archive/2007/05/09/exchange-2007-update-rollups.aspx.

Diamondas, No problems so far on the update. Rollup 5 will be released today at 10 AM on Microsoft Update as mentioned above. Rollup 4 will be offered to the computer via Microsoft Update (MU) if you do not have Rollup 4 installed and have installed Rollup 5. This is a limitation of the detection logic and I am working on addressing this. It isn't critical and it can be a little confusing. It will only happen if you are in this scenario and it will happen for about 2-3 weeks until the newer rollup is released.

Robert, The NGEN issue is still there where it can take forever. We have a prototype of the fix in test but it isn't really improving the time that I would like to see. We are still working on it.

Korbyn, For your cookie issue - do you happen to have a Windows 7 DC?

Did I miss a comment that needs to be answered? Let me know.
Not applicable
Nope, no Windows 7 DC's, strickly Windows 2003 DC's.  I haven't worked in any sites yet that are even ready to try W2008 DC's yet, let alone touch Windows 7...

Still actually fighting to get the MS08-035 patch installed, but this one DC is even giving the Domain Admin's an access denied error.
Not applicable
It appears that Exchange 2007 rollup 5 is on MU today.  Are there plans that these releases will be published and documented as being released either here:
Description of Software Update Services and Windows Server Update Services changes in content for 2008:

or here:
New, Revised, and Rereleased Updates for Microsoft Products Other Than Microsoft Windows:

Please can we have standard places to go to confirm what has been released on MU?

Not applicable
I forgot to mention it. The reason why I posted earlier was to let everyone know and I was distracted by the bright lights.

Thanks Susan.

For your other questions, it looks like the release didn't make it into the documentation that you pointed out. I am following up with Microsoft Update.

Not applicable
"It isn't critical and it can be a little confusing. It will only happen if you are in this scenario and it will happen for about 2-3 weeks until the newer rollup is released. "

Huh?  So if we install rollup 5 and we're offered rollup 4 is it okay to install it anyway?  What will happen?
Not applicable

Sorry about that. If you install Rollup 5 and then proceed to install Rollup 4, the MSI Service will examine the installation needed and determine that the files in Rollup 5 are newer than what is in Rollup 4. Rollup 4 will go through the motions of installing and will do very little to the machine except stop and start services (ServiceControl.ps1), register the OWA VDIR (updateowa.ps1), and a couple of other things not worth mentioning in a blog post.
Not applicable
Well ... after many a successful update I can say that RU5 has been the worst experience.

1. Install wouldn't start because Transport Service was hung on stopping. After waiting 1 HR!!!! all but MAD had finally stopped. Given it's 3 AM I finally lost my patience and restarted the server since the update hadn't started applying.

2. Restarted and services started up normally. Reapplied RU5 and this time the update goes through. YAY I think prematurely.

3. Reboot and service failures. Go into Service Manager and all but a couple of my Exchange Services are disabled. Obviously the successful update forgot to reset the service startups to the appropriate pre-install state. I dig around and figure out what needs to be what and start services. Great, I think ...

4. OOPS, forgot about IIS and a few other services the installer disabled. Reset those.

5. Try and logon to OWA and strike 3. Blank page though I've never customized logon.aspx.  Still trying to figure this one out.

Seems like this one was pushed out a bit early!
Not applicable
Anyone know where RU5 stores its install logs? I'm wondering if some other service is disabled.

IE won't even bring up the logon page (Page errors). FF at least brings be to an unformatted page and logs in to a messed up looking page with my MBX but no formatting again.
Not applicable
After installing Exchange rollup 5 SP1, my Exchange backup thru Symantec Backupexec is hanging when trying to backup my Exchange stores. It has been over 11 hours and the backup is still running. I was hoping that it would fix the problems caused by rollup 4, which has been causing MAPI and Exchange VSS Writer errors, and no good backup for a month. I have opened tickets with both Symantec and Microsoft Support, and 1 month later still no resolution...and only 1 good backup wich is not 2 weeks old. I just dont get where the head of these people are that put out these updates. They fix 1 problem, but cause 10 more!
Not applicable

You can get the servicecontrol.log in %SYSTEMDRIVE%exchangesetuplogs
Not applicable
Hi Scott,

We logged a case with PSS and it appears the problem is due to the fact we deployed RU5 through the updates folder. If we do the manual upgrade after deploying the SP1 binaries first the config files get updated manually.
Not applicable
Asif we are having the same problem, have you had luck with any solutions?
Not applicable
Tomorrow would be 3 weeks after Nov 21, will it be hitting microsoft update soon?
Not applicable
Any known issues with Entourage?
Not applicable
Rollups are released on Microsoft Update, suggesting that automatic installation is possible and/or recommended.

Has there been any changes to alleviate the need to unhook MS ForeFront before applying updates and service packs to Exchange?

The unhook is recommended in http://support.microsoft.com/kb/929080
Not applicable
OK, I see update 5 on my Windows 2003 servers when I go to MU, but I dont see it on my Windows 2008 servers.  I am currently at Rollup 3.  Do I need to wait longer, or is this still broken?
Not applicable
I installed Update 5 last night, and it seemed pretty smooth. It took about 30 minutes, mostly stopping the services, and required a reboot.  I should mention that this is a new server, and only lightly loaded.
However, I have an OWA user reporting this morning that when choosing the 'private' computer option, he gets logged out after less than a minute. You are then not able to log back in (even with a new browser session). I have found that I can repeat this problem. Any ideas, Please?
Not applicable
Installed Frsh Exchange server, tested everything working.

Then i updated to Rollup pack 5 : I'm getting the same error as GabrielV

Have you investigated that ?
Not applicable
Odd problem that appeared after I installed this rollup just over 2 days ago.  Two servers - CAS frontend, MB backend.  Updated the CAS first.

Only ONE user (so far) has begun experiencing the generic HTTP 403 (access denied) errors, when using webmail or ActiveSync on his Windows Mobile phone.  Refreshing the OWA session window or re-initiating an ActiveSync manually works fine.  But initially he always gets this error.

As a side note, his account had long ago been a Domain Admin, and so when I first set up the Exchange 2007 server and moved his mailbox to it, I encountered the known problem with his Active Directory account not being set to inherit permissions, thus blocking him from using OWA at all.  I corrected that at the time using ADUC, and it's still set correctly to inherit.

Has anyone seen this?  Any ideas?
Not applicable
Installed Update Rollup 5 for Exchange 2007 on SBS 2008 and it ran without a glitch (unlike Rollup 4 which screwed up OWA).
Not applicable
Since installing RU5, our users have noticed that the body text of plain text messages are rendered in a very small point size in OWA light/non IE browsers. It does not affect   OWA Premium & IE.

If I inspect the page elements it says 'font size="2"' (style font-size=10) in Outlook Web Access Light. There's no way that it's a 10 point font that's being displayed - it's more like 6 point courier.

We did not have any OWA customizations.

Anyone else seeing this?
Not applicable
Update to my issue above from 12/16/08, in case anyone else encounters it: I disabled the OWA and ActiveSync permissions on the affected account, waited a few minutes, then re-enabled them, and it's working fine.
Not applicable
I was so good without sp1 on my exchange 2007. no errors no bugs no nothing. But because of the public folders management I had to upgrade yesterday to sp1 and since I made it this far I thought that I should apply RU5.
Since yesterday i have only ASp errors in my logs.
Any ideas what I should do at this point ?
This is just a sample

hread information:
   Thread ID: 9
   Thread account name: NT AUTHORITYSYSTEM
   Is impersonating: False
   Stack trace:    at Microsoft.Exchange.Clients.Owa.Core.Utilities.GetEmailAddressIndexForContact(String itemId, String routingAddress)
  at Microsoft.Exchange.Clients.Owa.Core.AutoCompleteCacheEntry..ctor(String displayName, String smtpAddress, String routingAddress, String alias, String routingType, AddressOrigin addressOrigin, Int32 recipientFlags, String itemId, EmailAddressIndex emailAddressIndex, Int16 usage, Int64 dateTimeTicks, Int16 sessionCount, Int16 sessionFlag)
  at Microsoft.Exchange.Clients.Owa.Core.AutoCompleteCacheEntry.ParseEntry(XmlReader reader)
  at Microsoft.Exchange.Clients.Owa.Core.RecipientCache.ParseRoot(XmlReader reader)
  at Microsoft.Exchange.Clients.Owa.Core.RecipientCache.Parse(Stream xmlStream)
  at Microsoft.Exchange.Clients.Owa.Core.RecipientCache.Load(UserConfiguration configuration, Stream xmlStream)
  at Microsoft.Exchange.Clients.Owa.Core.RecipientCache..ctor(UserContext userContext, String configurationName, Int16 cacheSize, UserConfiguration configuration, Stream xmlUserConfigurationStream)
  at Microsoft.Exchange.Clients.Owa.Core.AutoCompleteCache..ctor(UserContext userContext, UserConfiguration configuration, Stream xmlUserConfigurationStream)
  at Microsoft.Exchange.Clients.Owa.Core.AutoCompleteCache.FinishSession(UserContext userContext, UserConfiguration configuration, Stream xmlStream)
  at Microsoft.Exchange.Clients.Owa.Core.UserContext.Dispose(Boolean isDisposing)
  at Microsoft.Exchange.Clients.Owa.Core.UserContextManager.TerminateSession(UserContext userContext, CacheItemRemovedReason abandonedReason)
  at Microsoft.Exchange.Clients.Owa.Core.UserContextManager.UserContextRemovedCallback(String key, Object value, CacheItemRemovedReason reason)
  at System.Web.Caching.CacheEntry.CallCacheItemRemovedCallback(CacheItemRemovedCallback callback, CacheItemRemovedReason reason)
Not applicable
Had the same issues as Karan - very messed up OWA interface, no images or formatting after the update. Attempting to back to RU4 as we speak...
Not applicable
Last night I installed RU5 on 3 production servers that were at RU1. I had to uninstall it from the Edge server because Exchange Credential service would not start. (Had no problems on Edge server in test lab.) Notable event in app log is from source MSExchange Common with description "Watson report about to be sent to dw20.exe for process id: 2040, with parameters: E12, c-RTL-AMD64, 08.01.0336.000, EdgeCredentialSvc, unknown, unknown, S.ServiceProcess.TimeoutException, 0, unknown.  ErrorReportingEnabled: False"  

Has anyone run into this problem or have suggestions on how to resolve it?  Or do I need to open a case with PSS to look at this?
Not applicable
Have two Exch 2007 SP1 servers utilising SCR. Have applied RollUp5 to one server and am now having problems with SCR. Decided to recreate the SCR links from scratch and the commands now insist on using FQDNs for server names.
For example in SP1 Rollup 4 the following command works
Update-StorageGroupCopy -Identity "EX1SG1" -StandbyServer EX2
Since SP1 Rollup 5 I get the error
Update-StorageGroupCopy: nodeFQDN EX2 is not a Fqdn name
All documentation I look at does not indicate that FQDNs are needed, is this a feature of Rollup 5 or has the install been corrupted???
Not applicable
I am very new to SBS 2008. Rollup 4 seems to cause all sorts of problems with exchange no text, pictures, lots of red x's in the RWW.  We have uninstalled it. Can I skip to Rollup 5?
Not applicable

Yes. You do not have to apply every Rollup sequentially.