SOLVED

Seemingly correct formula...incorrect?

%3CLINGO-SUB%20id%3D%22lingo-sub-2465538%22%20slang%3D%22en-US%22%3ESeemingly%20correct%20formula...incorrect%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2465538%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EEach%20time%20I%20type%20a%20formula%20(to%20create%20new%20rules%20to%20highlight%20cells%20for%20example)%2C%20an%20error%20message%20appears%20and%20says%20the%20formula%20is%20incorrect.%20Plus%20it%20doesn't%20say%20where.%20Yet%20the%20formula%20is%20very%20basic%20and%20seems%20perfectly%20correct.%3C%2FP%3E%3CP%3ECould%20you%20please%20help%20me%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2465538%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2465544%22%20slang%3D%22en-US%22%3ERe%3A%20Seemingly%20correct%20formula...incorrect%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2465544%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1083679%22%20target%3D%22_blank%22%3E%40Serena320%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EMake%20sure%20that%20you%20use%20the%20correct%20separator%20between%20arguments%20of%20a%20function.%3C%2FP%3E%0A%3CP%3EIf%20you%20use%20point%20as%20decimal%20separator%2C%20use%20comma%20between%20arguments%2C%20for%20example%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3DVLOOKUP(A2%2C%24F%242%3A%24G%24100%2C2%2CFALSE)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20use%20comma%20as%20decimal%20separator%2C%20you%20should%20(probably)%20use%20semicolon%20between%20arguments%2C%20for%20example%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3DVLOOKUP(A2%3B%24F%242%3A%24G%24100%3B2%3BFALSE)%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello,

Each time I type a formula (to create new rules to highlight cells for example), an error message appears and says the formula is incorrect. Plus it doesn't say where. Yet the formula is very basic and seems perfectly correct.

Could you please help me?

3 Replies
best response confirmed by Serena320 (New Contributor)
Solution

@Serena320

Make sure that you use the correct separator between arguments of a function.

If you use point as decimal separator, use comma between arguments, for example

 

=VLOOKUP(A2,$F$2:$G$100,2,FALSE)

 

If you use comma as decimal separator, you should (probably) use semicolon between arguments, for example:

 

=VLOOKUP(A2;$F$2:$G$100;2;FALSE)

Thank you very much.
Replacing comma by semicolon worked well.

This brings me to another question..
I started learning how to use Excel very recently with an online training. In the video showed, everyone seems to be fine using comma in the same formula as mine. How come I have to use semicolon when they don't?

@Serena320 

 

It depends on your system settings. Most tutorial websites and training videos assume that you use a point as decimal separator: for example two-and-a-half is written as 2.5 as is usual in the USA and UK.

On such a system, you need to use a comma between function arguments.

 

But in many other countries, a comma is used as decimal separator, so that two-and-a-half is written as 2,5

In that case, you need to use a semicolon between function arguments.