Not getting an option to sort largest to smallest, only A to Z

Occasional Contributor

I have a problem with my Excel spreadsheet where I do not get an option to sort numerically in descending order - largest to smallest. I only get an option to sort alphabetically. The cell values are either blank or numeric. Each cell is using the following formula - =IFERROR(VLOOKUP($P10, May3List, 6, FALSE), “”).

12 Replies

@RohitNaval Then I suspect that your "numbers" are in fact texts. What do you get when you enter =ISNUMBER(<cell reference>) where the cell reference is a cell where you have the number? FALSE? Then it's not a number. If not, perhaps you can upload an example of your schedule.

best response confirmed by Grahmfs13 (Microsoft)


In addition, you don't have blank cells, you have cells with empty texts returned by =IFERROR(...,""). As soon as we have texts within the range, even empty, Excel suggests to sort alphabetically. With =IFERROR(...,0) most probably that will be numeric sorting.

ISNUMBER returns TRUE for cells where I have a number and FALSE where the cells are empty.

@Sergei Baklan That is exactly what's happening. Most of the cells are empty and Excel is defaulting to sort alphabetically. Any way to change that sort option to numeric?


I did change the IFERROR formula from "" to 0 and now the sort works numerically. However I have so many zeros showing now. 

Oh that's perfect. Thank you so much for that settings tip.

While I have you, when a cell shows a green flag in the upper left corner, what does that indicate and how do I get rid of it? I have to manually get rid of it by selecting 'ignore error'.


Green "flag" is usually when one of this error appears if your settings are ON


You may switch above settings off, but I'd not recommend. You may select at once all such cells and ignore if that's only alert or correct if these are actually errors.



@RohitNaval I tried filtering my numbers but it just went 1, 220, 34, 460 etc instead of smallest to largest. I fixed it by converting the column I was trying to filter into NUMBER and then doing text to column. For some reason it wasn't converting to numbers until I did text to column. After that it allowed me to filter smallest to largest (1, 34, 220, 460 etc).


If you sort texts which option shall appear


"For some reason it wasn't converting to numbers until I did text to column." YES this finally works now. I was getting so frustrated. @annabellas 

I do the first option