SOLVED

WVD - Visual Studio 2019 on Windows 10 - Image not available.

New Contributor

I am trying to create a host pool (in Southeast Asia) and add VMs to it using portal. I have selected the VM Image of Visual Studio 2019 (Tried with Community and Enterprise) on Windows 10. This image is standard available from marketplace. I tried it 3 times and all the times it failed to find the image. The error is:

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"BadRequest","message":"{\r\n \"error\": {\r\n \"code\": \"InvalidTemplateDeployment\",\r\n \"message\": \"The template deployment 'vmCreation-linkedTemplate-39e2c88a-3587-47e4-ad37-47cde9049023' is not valid according to the validation procedure. The tracking id is '1d310798-53ed-44a1-9463-25b420dd80d1'. See inner errors for details.\",\r\n \"details\": [\r\n {\r\n \"code\": \"InvalidParameter\",\r\n \"target\": \"imageReference\",\r\n \"message\": \"The following list of images referenced from the deployment template are not found: Publisher: microsoftvisualstudio, Offer: visualstudio2019, Sku: vs-2019-ent-win10-n, Version: latest. Please refer to https://docs.microsoft.com/en-us/azure/virtual-machines/windows/cli-ps-findimage for instructions on finding available images.\"\r\n }\r\n ]\r\n }\r\n}"}]}

Please guide me to create this Host Pool.

2 Replies
best response confirmed by Eva Seydl (Microsoft)
Solution

@Subodh_Sohoni if you run 

 
$locName="southeastasia"
Get-AzVMImagePublisher -Location $locName | Select microsoftvisualstudio
 
you will see that there are no images from that publisher in Southeastasia region. I would advise to escalate to Azure support and file a bug on the images not being available outside. Alternatively deploy a windows 10 enterprise and manually install VS.
# list all the images
az vm image list --all --output table --publisher MicrosoftWindowsDesktop
# Get the lastest enterprise image version
lastest=$(az vm image list --all --output table --publisher MicrosoftWindowsDesktop | grep " 20h1-ent " | cut -d' ' -f5- | tail -1 | awk '{print $2}') \

az vm create \
--name AAAA_JUST_A_TEST \
--resource-group rg_WVD \
--location southeastasia\
--image $lastest \
--size Standard_D2_v3 \
--admin-username adminxxx \
--admin-password pwxxxxx \
--accelerated-networking false \