Can not connect to WVD RDS session host unavailable


I created a new WVD for a customer this morning using the newly updated image.


using get-rdssessionhost


status says unavailable I can see the session desktop in the html5 browser but it does not connect. No errors on the join process 

12 Replies

Unavailable is reported for cases where service is unable to reach the VM to establish the connections. This can happen when either the VM is shutdown or if there are issues with domain, network or agent. Can you ensure VM is booted up and get us output of following two commands:


Get-RdsSessionHost -TenantName <TenantName> -HostPoolName <HostPool> -Name <hostname>


$h = Get-RdsSessionHost -TenantName <TenantName> -HostPoolName <HostPool> -Name <hostname>
ConvertFrom-Json $h.SessionHostHealthCheckResult  

Take one of the following actions to resolve.

Manually add the VMs to a domain.

Redeploy the template once credentials have been confirmed. See Create a host pool with PowerShell.

Join VMs to a domain using a template with Joins an existing Windows VM to AD Domain.

I got it fixed i appreciate all the replies

Hi @tommy_barnes , 


can you share your solution or what things you did that finally fixed it ?



Hi Tommy,


What did you do to fix it?  Do you have a link or something you could share?





Sorry for the late response.  I ended up deleting the setup and recreated setup all from powershell and then i set up everything

Can you elaborate on what you did to troubleshoot the issue? I ran into the same issue @tommy_barnes 

I had a similar issue. After deploing our custom image, the RDS session hosts wold become unavailable.
We used Win 10 multi session as the base, the 2004 build. I traced the issue back the RD agent deployment. The SxS stack was not enabled.. I loggd into the session host via the bastion connection. Everything was fine. No major errors anywhere. I noticed that we had multiple versions of the we had multiple versions of the Remote Desktop Services INfrastructure Agent installed. I removed the old ones and kept the newest one.  I re-ran the script in the C:\DeployAgent\EnableSxSStackScript folder to register/start the Sxs stack and restarted the machine. It should have been registered/started on the initital deployment, but for some reason it didn't trigger.. I'm still trying to figure out why. That appears to do the trick for us.


I finally figured out why we had problems.. I should have posted this sooner.. Someone had pushed a GPO that messed up the SXS stack.. Specifically a GPO that enabled the following setting: "Configure: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Application Compatibility Turn off Windows Installer RDS Compatibility - enabled"
That was enough to break WVD.. We removed that, and everything started working properly.

I've noticed this on a few deployments so far.

I would log into the session host with the issue and, run qwinsta and find that the SxS stack wasn't loaded.

I would programs and features for any updates and find that a new version of the SxS stack was installed but the old version would still be there. I uninstall the old version and leave the new. Reboot and we're back. Still gathering more info to see if this is the actual fix or just a lucky reboot.