Error Loading Extension and Definition in Azure Windows Virtual Desktop Deployment

Copper Contributor

I recently created a new Windows Azure trial account and have a problem deploying Windows Virtual Desktop. Each time I try to create a new host pool it will prompt me with the ErrorLoadingExtensionAndDefinition reason code. 


I have contacted Azure technical support and they suggested that I post this on the forum for assistance as this error has also impacted multiple customers. 


Here's the full error summary. Hope someone can help me find a workaround so that I can deploy Windows Virtual Desktop.


{ "shellProps": { "sessionId": "56c957f1339a4fd6af1852baf5372040", "extName": "Microsoft_Azure_WVD", "contentName": "HostpoolBlade" }, "error": { "message": "Error displaying your content", "summaryItems": [ { "label": "Error reason", "value": "ErrorLoadingExtensionAndDefinition" } ], "details": "message: Cannot read property 'id' of undefined\r\nstack: ###_RPC_Exception_###\nTypeError: Cannot read property 'id' of undefined\n at s.n (\n at new s (\n at y (\n at\n at t._dispatch (\n at t._get (\n at t.get (\n at new t (\n at\n at o (\r\nFrom RPC: fx -> Microsoft_Azure_WVD (MsPortalFx.Internal.Constants.RpcMethods.tryEarlyGetViewModel)\r\n(Callstack capturing is not enabled. Use ?trace=diagnostics to enable it.)\r\n", "code": null }}

10 Replies

@StevenSolomonI'm seeing the same thing, created a post a little while ago -

I found you can create a host pool using Powershell - - but I'm now stuck because you get the same error in the portal when you try to add session hosts to the pool and I can't see a way to add sessions hosts using PS.

It seems if you use the old deployment (Pre-Spring 2020) method it at least does no error out immediately.




Same issue here I have been working with MS engineers for 6 weeks now and nothing!!!

 Screenshot 2020-10-01 142809.png

I am also getting similar error while creating a new resource. It is not able to load Azure Marketplace.





Have the same issue on Chrome, opened it in Edge and worked fine! Whenever we interact with the Portal, Azure, Office 365 etc we always use Edge as it acts very different in other browsers. 

I also got same issue today while creating storage, Tried by Microsoft Edge and it worked, Thanks
Worked for me too by switching browser to MS Edge.

Hi All,
Hopefully this helps with anyone dealing with this in 2023:
when seeing the page with the error I found running the self diag tool worked. give it a try and then refresh.