Multi-monitor issues on primary

Iron Contributor


This seems to be getting worse for some reason.  Users are complaining that they either get a black primary desktop, its offset or just sticks with the preparing windows screen, its as though it fails to do its final refresh.

In the screenshot it shows the primary screen stuck on the preparing windows, its still offset to the left leaving black down the right hand side. Can control the start menu with the second screen. 


Tried setting it to Window and back again. Does not refresh and actually goes black at this point.


Only way to get it to work is to disconnect the session, log back in and it refreshes and works fine.   This is driving users crazy.  I thought it may be RDP properties issues. I have reset these back to default.  Same result.

Using latest version of RDP Client.

Single monitor mode works fine first time every time.


Anyone come across a similar issue?


Screen issues.png


7 Replies

Just to give you an update. Looks like users are experiencing this if they use UDP shortpath, once we disabled UDP and enabled TCP only all was well. We suspect the firewall is causing this so we are going to deep dive into this. So at the moment we are disabling UDP for the tenant

Thanks for the follow-up and additional details.. Helpful troubleshooting tip! If it further gets resolved keep us all posted.


So this is not network related but seems to be a bug with a couple of the Host Pools.
The pools have exactly the same RDP Properties.

If you log on with Multi-monitors the main display is all offset. As a test we then moved the same session host so another pool which doesn't seem to have this issue (Same GPO's, Network etc). No further issues.
Moved the session host back, main screen all offset again.

We have a case open with Microsoft, even the new test pool I created has the same behaviour.


Thanks aton for another round of due diligence looking forward to the final resolution or workaround.
Hi @KevHal @askaresh
We have the same issue. Do you have any update from Microsoft, please?
Did you ever get this fixed? We're having this issue on every AVD pool with W11MS. Disabling RDP Shortpath hasn't helped.