Windows 10 Version 1809, Remote Desktop Connection not working from PC but working fine from macOS.

Harry Kim

Updated yesterday to version 1809,

Remote Desktop Connection from another Windows 10 version 1809 not working.

It looks like connected, but the whole screen is blank and the mouse cursor become hourglass then about 1 minute later, lost connection. Then trying to re-establish the connection, but the screen is still black. This time mouse cursor even stuck and not showing in the screen. 


58 Replies

I have the same problem. The old version of mstsc (windows 10 1709, windows 7, Android version) can connect smoothly. However, the mstsc of windows 10 1809 cannot connect. While connected, the screen freeze. 

I've got the same problem.  I tried to log into my remote PC yesterday (both local & remote have been upgraded to 1809).  Out of 5 attempts one was successful - the other 4 attempts resulted in the screen freezing in one form or another).


A fix for this would be gratefully received - I and my organisation are rather dependent on remote connections.

Same problem. A black screen. Can confirm that the cumulative update didn't resolve this. 

The only one solution is to, use the computer network name not the ip adress. But this is a half solution......


Have a nice day

As it happens I was using the machine address and not the IP address and it was not working using the machine address.  I can't check this any further at present because I've rolled back to 1803.


One thing that seemed odd was that I was able to remote desktop using a machine on the local network, but not over a vpn connection (and I did check the vpn was working correctly by connecting to other machines that were not updated to 1809).

Same problem here, my rdp server is behind a router with portfoward.

On my computer I can connect from my office but not from home (both places behind NAT)

I have no idea why it works from my office, before 1809 it worked from anywhere.



Exactly the same with me.


RDP between office computers work fine. Between computers at the house works fine. Home to the office works fine, but from the office to home, black screen.


Been using Remote Desktop Connection Manager in the meantime. Works okay, but not preferable.


Also, it makes no difference if I use the fully qualified name or the ip.





Are we talking 1809 to 1809 systems? If  so, then ignore below text. :-)


Was the 1809 system the remote. or was it initiating the Remote Desktop? What version was the remote system?   I have an 1809 system that can connect to an 1803 system fine. And, the 1803 can connect to 1809 fine.


I have not tried connecting through VPN or NAT router.

Yes. Sorry, I should have mentioned that all systems were 1809.

Same issues with RDP. Cannot connect to remote session.

Also seeing this problem. When logging in remotely from a PC running 1809 to another PC running 1809 over the WAN RDP draws the first few frames and then suddenly locks up.

I do have the same problem (as Munn). The only workaround is to enable "Turn Off UDP On Client" in the group policy editor.

I have the same problem. Remote Desktop client stopped working right after this update. Very frustrating. Still reading but I hope there is a fix.

Ditto to all the above symptoms, 1809 version, cannot connect to any RDC enabled OS (W2008 - W2016)

Which blows, as I have several hundred RDP sessions saved. :-/


If you are in a pinch, download the remote desktop app, at least you can connect on the fly until this is fixed or until you can try the UDP disable reg settings mentioned



Just tested on 1809.

Made a connection from a windows 10 1809 client to a windows 10 1803 client, via hostname and via IP, both seem to work, so OK.


From the same machine, made an RDP connection to a Windows Server 2012 R2 via hostname and IP, screen stays blank for a bit longer, but eventually working. So also ok.

The problem happen only if enabled the UDP on Remote Desktop Connection in 1809

The UDP  enabled automatick


So how can desable the UDP ???

in case if you are still looking for a solution for this one. Enabling Turn Off UDP On Client worked for me.

Open gpedit and navigate to computer configuration\Admin Templates\ Windows Components\Remote Desktop Services\ Remote Desktop Connection Client

Enable Turn Off UDP On Client apply and try connecting again.

I hope this helps

To disable UDP on client machine.

Open gpedit and navigate to computer configuration\Admin Templates\ Windows Components\Remote Desktop Services\ Remote Desktop Connection Client

Enable Turn Off UDP On Client apply and try connecting again.

I hope this helps

Same problem here, but I can confirm that I, in fact, have control! Once I opened a folder full of Microsoft Virtual Academy videos. Then, I connected using Remote Desktop. I double-clicked somewhere in the black. The target computer started playing an MVA video: I could hear the video's sound through the target computer's speakers. When I logged in via the console, I saw the video player was on screen.

Same stuff, different day, or how it goes. I have the same problem. Good job MS, on Your third iteration of 1809, which forced unto my work computer and now I need to pay for AnyDesk in order to use it full time. "Good job, really good job"

Okay, so Sys Admin at the company I work at told me, that there's some chance that Remote Desktop Connection and Remote Assistance [which use the same GUi and libraries] have most likely been severed. Now You need to issue invitations. It works for me via invitations. I have Windows 10 Home @ work and Windows 10 Pro @ home, so I can connect, via invitation. I switched to TightVNC and original RealVNC client. Works much better.


//edit: Well, not even dayum invitations are working :(



I stumbled across a similar problem.


Between 2 Win10 Pro 1809 I only got a black picture, but I could control the computer in the session: It was possible to write texts, click icons and move windows.

After some debugging I noticed that I had different MTU settings for host and client.


I then tested the following settings:


  • Host: jumbo frames 9k + client: jumbo frames off = black screen as described above
  • Host: jumbo frames off + client: jumbo frames off = runs immediately
  • Host: jumbo frames 9k + client: jumbo frames 9k = runs immediately
  • Host: jumbo frames off + client: jumbo frames 9k = frozen waiting-cursor with login image, which is also frozen. After approx. 40 sec. desktop appears and it seems to work normally

I hope I can help someone with their problem.


sincerely yours,




Translated with


disabling UDP did the trick for me!

Kudos to Maydogan & ITManager from bringing this (temporary) workaround!


Hey there buddy,

Use RDC Wrapper.

It helped me. You need to find exact configuration for Your current Windows version.

Wrote to Windows live support, they told me that RDP Wrapper is not illegal so that's that.

With kind regards


seriously microsoft it's time to fix this. It's confirmed that disabling UDP in firewall to the RDP-host is a fix for this, so why don't you fix it? I can't go around blocking udp everywhere.

This is hurting.

Has anyone here tried reporting it to Feedback Hub? If yes, please share your link so that the rest of us can upvote. After all, that's the official way of getting Microsoft's attention.

I think the issue discussed at


stems from the same problem, or is in fact the same issue.


Just like here, Microsoft also ignores them there.

Microsoft ignored? Did you try getting Microsoft's attention in the first place? The correct way of doing it is to post to Feedback Hub and share a link to the report here, so we can upvote it.

We recently experienced this when using RDP from Windows 10 v1809 to another Windows 10 v1809 machine. This worked for us.


Add a new registry entry in:

"HKLM:\Software\Microsoft\Terminal Server Cient"




Supposedly Microsoft is working on releasing an update sometime in April that fixes this issue.

Yeah we know the workaround.. Great but editing the registry is not an acceptable fix!

Thanks for your update and contacting us.

If the registry workaround the issue, then mostly this KB should fix it :

install on both client and server ( source, destination) 

If you still experience the issue, please do let us know. So we can help you further. 

@FerasShehadeh wrote:

Thanks for your update and contacting us.

If the registry workaround the issue, then mostly this KB should fix it :


If you still experience the issue, please do let us know. So we can help you further. 

Nope, I just installed this update on my Windows 10 laptop and still having the same problem connecting to a 2019 server...

Would you please confirm if this KB installed on both OS (source and destination). I meant install the KB on client and server.


What is the Hyper-V OS running ?




The latest update has indeed fixed this issue. Thanks MS

the KB is installed on both machines, I dont user hyper-v at all. Windows 10 pro on both machines.

The issue is not with the server but with the client. It doesnt matter what version the server is, 1809 clients cant connect if udp isnt disabled.

What happens is you get past the login but then the screen is just black.

Only if UDP disabled, client will experience black screen?
And if you enable it, client will connect normally ?


It's the other way around, only if you disable UDP it works. 

So by default it does not currently work.

Alright will check and get back to you.

This fix should address the same issue, but will check if we have the fix with the KB or not and update this thread.

one quick questions, check rdpbase.dll version ?
and what Client windows 10 you are using ?
Are you using any VPN in between client and server?

Hey all,


I am having trouble replicating this issue. I have a couple of PCs running 1809 (17763-316) and I cannot get the black screen. I have tried RDP from PC 1 to PC 2, it works fine. I has also tried PC2 to PC1, it also works fine.  Adding a 3rd PC (laptop) to the mix, I did PC3 RDP to both PC1 and PC2. Worked fine.  And RDP from PC1 and PC2 to PC3. Worked fine.


Of course all are the 1809 listed above. I guess I am doing something right, or have just been spared. I don't know.


dll version is 10.0.17763.348.

Im using the default rdp client, not the one from store.

There is no vpn involved, open connection over the internet.

The RDPBASE.DLL is 10.0.17763.1 (9/15/2018)

As told before, 1809 17763.316

Using NordVPN on PC2 I was able to RDP to both PC1 and PC3 (laptop). Worked fine. My Asus Merlin router is set with different ports for RDP.


All good here. <shrug>



If you scroll up, I did test without VPN. I used 3 PCs with 1809 17763.316. All worked fine. No black screens.

Related Conversations