SharePoint + Microsoft Edge Chromium Issue with installing VSTO file

%3CLINGO-SUB%20id%3D%22lingo-sub-1907092%22%20slang%3D%22en-US%22%3ESharePoint%20%2B%20Microsoft%20Edge%20Chromium%20Issue%20with%20installing%20VSTO%20file%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1907092%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20currently%20host%20%3CSTRONG%3EClickonce%20installers%20(VSTO)%3C%2FSTRONG%3E%20in%20%3CSTRONG%3ESharePoint%20Document%20Library%3C%2FSTRONG%3E%26nbsp%3Bto%20distribute%20the%20Word%20Addins%20to%20users.%20Until%20now%20most%20of%20them%20used%20%3CSTRONG%3EInternet%20Explorer%3C%2FSTRONG%3E%20and%20when%20clicking%20on%20VSTO%20file%2C%20it%20installs%20the%20word%20addin%20directly%20from%20SharePoint%20and%20it%20also%20helps%20in%20releasing%20the%20future%20addin%20updates.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CU%3E%3CSTRONG%3EProblem%3A%3C%2FSTRONG%3E%3C%2FU%3E%20We%20are%20currently%20migrating%20to%20Microsoft%20Edge%20Chromium%20browser.%20When%20we%20click%20on%20the%20VSTO%20file%2C%20it%20downloads%20locally%20and%20installation%20fails.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CU%3E%3CSTRONG%3EAdditional%20Information%3C%2FSTRONG%3E%3C%2FU%3E%3A%20We%20tried%20hosting%20the%20VSTO%20installer%20in%20IIS%20directly%20and%20tested%20with%20a%20simple%20HTML%20page%20with%20the%20link%20to%20the%20VSTO%20file%3A%20It%20nicely%20installs%20the%20addin%20using%20MSEdge%20Chromium%20browser.%20We%20narrowed%20down%20that%20it%20is%20the%20SharePoint%2BMSEdge%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20faced%20this%20issue%2C%20it%20will%20be%20great%20if%20you%20could%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWe%20are%20currently%20using%3CSTRONG%3E%20SharePoint%202013%20with%20MSOffice%20Client%20-%20Word%20365%3C%2FSTRONG%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CSTRONG%3EMicrosoft%20Edge%20Version%3A%3C%2FSTRONG%3E%2086.0.622.69%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1907092%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Edge%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EVSTO%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

We currently host Clickonce installers (VSTO) in SharePoint Document Library to distribute the Word Addins to users. Until now most of them used Internet Explorer and when clicking on VSTO file, it installs the word addin directly from SharePoint and it also helps in releasing the future addin updates.

 

Problem: We are currently migrating to Microsoft Edge Chromium browser. When we click on the VSTO file, it downloads locally and installation fails.

 

Additional Information: We tried hosting the VSTO installer in IIS directly and tested with a simple HTML page with the link to the VSTO file: It nicely installs the addin using MSEdge Chromium browser. We narrowed down that it is the SharePoint+MSEdge issue.

 

Has anyone faced this issue, it will be great if you could help.

 

We are currently using SharePoint 2013 with MSOffice Client - Word 365

Microsoft Edge Version: 86.0.622.69 (Official build) (64-bit)

1 Reply
Did you ever find a solution? I am using MS Edge version 91.0.864.37 (Official build) (64-bit) and am having the same issue.