SharePoint Content Type and Document Template Form

Occasional Contributor

Hi everyone,

 

We migrated from 2013 to SPO using ShareGate. Everything looks pretty good for the most part. We have a library called "123". Three content types are associated with the library and were brought over with it: CTA, CTB, CTC.

 

When I previously selected New Document>CTA in 2013, a form would appear asking me to enter the metadata: Name, Year, Month, etc. (All metadata associated with the content type). I would enter this information and click "Save" and then WordWebApp would load. After saving, the document would be located in the library with all associated metadata entered on the form presented during creation.

 

In SharePoint Online (SPO), everything looks similar in the library (Modern view now), but when I select New>CTA it doesn't present the form to enter the metadata. It loads Word on the web and throws:

 

"The document you are trying to open is a template. Would you like to open and edit as a standard document?"

 

If I select "No", nothing happens and Word on the web stays blank with no UI. If I select "Yes", it loads Word on the web into a blank document but after saving, none of the metadata is saved for the record in the library.

 

I've fired up PowerApps and edited the form and all looks fine, I just can't get it to present at the creation of the document content type using "New" in the document library. Any ideas how to get that linked back up?

 

Thanks,

AA

1 Reply

Any thoughts on this?

 

It's basically the form won't load to enter metadata before the document is created. How can I trigger the form to load again? 

 

I've recreated the form in PowerApps, but I'm not sure how to the trigger the form to load when selecting the document template/content type from the "New" button in the library. 

 

Thanks,
AA