PDF content disappearing when viewing in SharePoint library

Brass Contributor

We're having a problem with a SharePoint online modern library in displaying PDF files content. The user will navigate to the document in the library, and the content shows at first, and then a moment later the content of the pdf form disappears. One thing to note is that in both Chrome and Edge that this is presenting in the same way for another user.  Even after clearing cache and restarting computer. For myself, in testing, it is only happening in Chrome and not Edge. I'm not sure if there are settings I am missing that is causing this, but would appreciate any help or thoughts in solving this. 


23 Replies

@Jennie Sheridan 


Also facing the same issue, when i am in the library and open one specific pdf file, part of the header starts loading and suddenly disappear.

Chrome and Edger have the issue happening, also tried both in a private window.

On Internet Explorer works just fine.

I'm having the same problem. I can reproduce the problem in several Chromium-based browsers (e.g., Chrome, Edge, Brave) as well as Firefox, so it doesn't appear to be Chromium specific. As @esilva_myPartner mentioned, the problem isn't present in Internet Explorer.

@billpcolden , @esilva_myPartner , have either of you noticed that it's not all PDF's and only some types of elements in PDF's?

Yes, I have noticed that it's not all PDFs in the document library. I haven't figured out the pattern yet. In my case, the PDFs with display issues appear to be PDFs that were edited/marked-up and then resaved to the document library.
I've also encountered this issue;

During testing, I noticed that not all PDFs encounter this issue, but I haven't found any real difference in the content of the document that might cause this behavior.

I also noticed that this issue occurs in Chrome, Edge, Opera, Opera GX, and Firefox - But as @esilva_myPartner mentioned, it does not occur in IE11.

I am kind of figuring that has to do with Internet Explorer using the system PDF viewer instead of the Sharepoint viewer, but I don't know for sure if that is the case.
We are experiencing this issue as well in Edge and Chrome. Not a problem in IE11..so this is a little puzzling. Any chance that this could be related to font type used? On some of the problematic PDFs here, I opened them in Illustrator to see if I could figure out what is happening but had noticed the content that were missing were also missing the fonts. What's even more confusing is that if I don't resolve the missing fonts, but just resave the PDF file, it will then render correctly in SharePoint PDF viewer. Could it be something related to how the document is converted?

This issue was reported to Microsoft but they found no issues. That was not helpful.
Also having this issue with some random PDF's lately. something with certain type of encoding or fonts or something must be causing this but the question is what. I can convert the PDF using flow actions and a service I have to a PDF/A and it works fine, but something with PDF files or the viewer has changed recently, as accounting has been reporting this more than once now over the past few weeks.

@Stephen Rice do you know anyone that might be able to look at this on the files viewer Team? I have an example document I can share as well if you want to reach out that has this problem. Seems something happened recently. I've noticed it in PowerApps, but I'm assuming it somehow uses the same file viewer as SharePoint / OneDrive as it happens the same there. Local Opening of document renders fine, and in Adobe.



Wondering if something with this layering tech in newer generated PDF Docs?

Wondering if the Online viewer is loading the layer, then it gets covered up once another layer loads over the text or something. Anyway, just tossing out clues to what I've found :P.
The content is showing up in dev tools but somehow these set whiteout to the viewers (text color is set to white). If you highlight over the missing document content, it will show where the content is but it still remains invisible from the viewers
Yeah, was noticing this as well. You can highlight where the Text is supposed to be but can't see it. Wondering if a logo is on a layer over the text somehow where it's a bunch of white space. Hard to pinpoint but def. something up there. I'm building a conversion button in my apps as a work around to convert to PDF/A which works fine, but it's costing money per conversion. Luckily it's low cost for now, but hopefully this doesn't spread bigger, so def. raising the flag here and try to determine if we need to educate document generators or if we can update the standards / view of the Microsoft PDF online viewer.
Ok, So a bit more information. This def. seems to be a Microsoft Viewer update issue. I went back and viewed invoices that worked before and were approved using my PowerApp / SharePoint viewers and they worked last month. I open those same files now via SharePoint and the text is missing. It def. seems related to invoices that are more "Text" like typerwriter looking than image like pdf's which seem fine, so there is something there.

Has anyone put in an official support ticket with Microsoft in this thread? I'm going to try to start one tomorrow when I get a chance, but def. can narrow down as a viewer / web update using the viewer causing this and not a pdf generation issue.

@Chris Webb I do have an official MS Support ticket in for this issue. I do think the more who create support tickets, the merrier, on that front though.

I also have an official MS Support ticket in for this as well. I agree that if we have more support tickets on this issue, this will show that this is affecting multiple users.
We see the same behavior with some PDF files. However, our staff circumvents by selecting the "Open in browser" option which successfully renders the document.

Also, if the user copies the file to OneDrive and uses Edge to open, the same document renders correctly without using the "Open in browser" option.

@Jennie Sheridan 

Im not in tech but have the same problem but not with all pdf's.  It seems to be a problem with PDFs that were created using a template.  Dont know if its a font issue?  I have three pdfs next to each other in a folder and two of the three open perfectly but this one that was made from a template just causes the problem but its only 80% of the text.  Again if I open in Browser all teh text appears

I was informed by Microsoft that a fix should be coming in September sometime. Hopefully, this will fix the issues you guys are experiencing.
It appears that the PDF rendering issues is resolved on our end. Hopefully it is for you guys as well.

As of 11/6/2021 I'm still having this problem with PDFs created from the latest version of Acrobat (OCR applied) and viewed in the latest version of Edge.  I note that the same document displays properly when reviewed on my iPhone using the Sharepoint App.