Add hubsite link not working correctly

Not applicable



I have recently registered a hub site and associated a site to that hub site.


I am trying to add the associated hubsite link to the Hub site navigation via the Add link option on the hubsite page. It opens the panel to add the URL and display name but upon clicking save nothing happens and nothing is added to the navigation.


See attached video of what is happening


Is anyone else experiencing this issue? 



12 Replies

I have the same problem as well. The add link to navigation does not seem to work.

Hi Josh,


I had the same problem when trying to do it using Edge, I tried in Chrome and it worked.


Not ideal, but hope that helps you.





Hey John,


i have tried Chrome, IE and Edge and still no joy :( 


count yourself lucky lol 

Ahh sorry man, that's all I've got!

Hope someone comes along with a better solution.



Same here. I tried it in Chrome and IE and nothing yet. 

best response


AddLink.PNGThere seems to be a bug with the 'Add link' option, but found a work around.  Cancel the window that opens up after you click on the 'Add link' and then click on the plus sign (+) above the Save and Cancel button.  This will open the same window that you have closed earlier but it does add the link properly and allows you to do multiple levels of links as well.   'Add Link' option will change to 'Edit' once a link has been added.

Thanks Anupam! Your workaround did work for now. 

My workaround was opening the chrome developer tools. Then it seemd to work.

Brilliant, that has worked for now.


Many thanks for your help Anupam!

Thanks for your help Martjin

Perfect workaround - many thanks


@Angus Hamilton 


End of 2002 and the bug is still there !!! Workaround works for me.