MS Syntex error after Publish. SharePoint library has been moved or deleted.

Copper Contributor

Hi Community,

I appreciate your help with this error. @Mario Fulan @Steve Pucelik @Wayne_Addison 

After doing a new training (adding new collections and modifying some tags) I proceeded to click on publish the last trained version to overwrite the current version

After that I get this error message that says
"It looks like that SharePoint document library has been moved or deleted. Go back to the SharePoint site and try again.

The model is created on the site in the library called "models". The security is the same and the library has not been moved or deleted.

The model is applied to another library called Invoices, it has not been moved or deleted either.

I don't know if the error is related to the Models or Invoices library. What do you recommend me to do?



3 Replies
Just to be clear, this is a Freeform or Layout model I assume? If it has already been deployed to a different library you can't deploy it to another library. It will only work on 1 library. If that's not the case, initiate the model revision from the library (click classify and extract) and then try to republish it that way.

Hi @Steve Pucelik 

Yes, it is a Layout model. And it was applied and deployed in the same library.


The "published" model is working correctly. The document I show in the following image was loaded a few minutes ago in the library that has the model applied.
As this document is "not trained on any collection" its information could not be fully extracted.

But the syntex processing finished correctly.




I am thinking that the problem is not with the Applied Library (Invoices), I think it is with the Models library where the model is stored. What do you think?


@Steve Pucelik

I just ran the following test and the same error is generated again.


I downloaded the model from the Models. I then uploaded the downloaded file with a different name.

The new version of the model has the published version and the latest trained version.


But as I informed you at the beginning, it generates the same error when I click on Publish.