SharePoint 2013 Search is not working on document library

%3CLINGO-SUB%20id%3D%22lingo-sub-818471%22%20slang%3D%22en-US%22%3ESharePoint%202013%20Search%20is%20not%20working%20on%20document%20library%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818471%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20an%20environment%20of%20SharePoint%202013.%3C%2FP%3E%3CP%3EWe%20have%20facing%20the%20issue%20with%20the%20search.%3C%2FP%3E%3CP%3ESearch%20is%20not%20working%20with%20the%20Document%20library%20search%20box.%20but%20enterprise%20search%20center%20global%2FSite%20level%20search%20box%20is%20working%20awesome%20and%20gives%20expected%20records.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20below%20solutions.%3C%2FP%3E%3CP%3E1.%20Re-%20index%20at%20document%20library%20level%20from%20advance%20setting%3C%2FP%3E%3CP%3E2.%20Run%20full%20crawling%20from%20Search%20Administration%3C%2FP%3E%3CP%3E3.%20Index%20Reset%20at%20Search%20service%20application%20in%20Central%20administration%3C%2FP%3E%3CP%3E4.%20Checked%20managed%20property%20and%20crawled%20property%20for%20Name%20Field%20in%20document%20library.%3C%2FP%3E%3CP%3EHere%20i%20have%20attached%20crawled%20Report.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F128069i4616A5980F2512CC%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22CrawlReport.png%22%20title%3D%22CrawlReport.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20am%20not%20getting%20what%20i%20missed%20while%20configure%20the%20search%20service%20application.%3C%2FP%3E%3CP%3ECan%20any%20one%20help%20me%20out%20for%20the%20same%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%26nbsp%3B%3C%2FP%3E%3CP%3EDipen%20Shah%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-818471%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%202013%20Search%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-823547%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202013%20Search%20is%20not%20working%20on%20document%20library%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-823547%22%20slang%3D%22en-US%22%3ESearch%20your%20document%20library%20url%20in%20crawl%20logs%2C%20you%20will%20get%20the%20reason%20why%20document%20library%20is%20not%20getting%20crawled.%20Crawl%20rules%20can%20be%20the%20reason%20for%20document%20library%20not%20getting%20crawled.%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi,

 

We have an environment of SharePoint 2013.

We have facing the issue with the search.

Search is not working with the Document library search box. but enterprise search center global/Site level search box is working awesome and gives expected records.

 

I have tried below solutions.

1. Re- index at document library level from advance setting

2. Run full crawling from Search Administration

3. Index Reset at Search service application in Central administration

4. Checked managed property and crawled property for Name Field in document library.

Here i have attached crawled Report.

CrawlReport.png

 

i am not getting what i missed while configure the search service application.

Can any one help me out for the same ?

 

Thanks in advance 

Dipen Shah

1 Reply
Highlighted
Search your document library url in crawl logs, you will get the reason why document library is not getting crawled. Crawl rules can be the reason for document library not getting crawled.