SOLVED

Invalid Package - SPFX Solution (solved)

%3CLINGO-SUB%20id%3D%22lingo-sub-76038%22%20slang%3D%22en-US%22%3EInvalid%20Package%20-%20SPFX%20Solution%20(solved)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76038%22%20slang%3D%22en-US%22%3E%3CP%3EStarted%20receiving%20Valid%20App%20Package%20%3D%20No%20today%20while%20trying%20to%20update%20an%20app%20package%20in%20the%20catalog.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooking%20at%20the%20unavailable%20apps%20view%20reveals%20the%20following%20error%20message%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EInvalid%20SharePoint%20App%20package.%20Error%3A%20Unable%20to%20cast%20object%20of%20type%20'Microsoft.SharePoint.ClientSideFramework.SPClientSideComponentMetadata'%20to%20type%20'Microsoft.SharePoint.ClientSideComponent.SPClientSideComponentMetadata'.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F15523iBBAE87074420934C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20also%20unable%20to%20rollback%20the%20solution%20to%20any%20previously%20working%20version%20as%20I%20receive%20the%20same%20error%20there%20as%20well.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76195%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76195%22%20slang%3D%22en-US%22%3EIt's%20fixed%20now%20for%20me%20as%20well.%20Thanks%20Pat.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76194%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76194%22%20slang%3D%22en-US%22%3EYup.%20I%20saw%20that%20one%20yesterday%20but%20started%20this%20thread%20because%20I%20was%20getting%20a%20different%20error%20message.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76176%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76176%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20-%20the%20middle%20problem%20was%20the%20same%20thing.%20%26nbsp%3BIt%20was%20fixed%20in%20that%20thread%2C%20but%20wanted%20to%20make%20sure%20you%20weren't%20hitting%20a%20different%20issue%20with%20a%20similar%20symptom.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76175%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76175%22%20slang%3D%22en-US%22%3E%3CP%3Eyou%20might%20also%20want%20to%20keep%20an%20eye%20on%20this%20one%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint-Developer%2FInvalid-Package-Sharepoint-Framework-Extensions%2Fm-p%2F75585%23M2576%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint-Developer%2FInvalid-Package-Sharepoint-Framework-Extensions%2Fm-p%2F75585%23M2576%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76174%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76174%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20was%20a%20bug%20that%20got%20out%20-%20we%20believe%20it%20should%20be%20working%20now.%20%26nbsp%3BCan%20you%20let%20us%20know%20if%20you%20are%20still%20running%20into%20the%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-76100%22%20slang%3D%22en-US%22%3ERe%3A%20Invalid%20Package%20-%20SPFX%20Solution%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-76100%22%20slang%3D%22en-US%22%3E%3CP%3ECould%20it%20be%20that%20you%20are%20using%20an%20older%20version%20of%20the%20SPFx%20as%20a%20base%20for%20this%20app%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Started receiving Valid App Package = No today while trying to update an app package in the catalog.

 

Looking at the unavailable apps view reveals the following error message: 

 

Invalid SharePoint App package. Error: Unable to cast object of type 'Microsoft.SharePoint.ClientSideFramework.SPClientSideComponentMetadata' to type 'Microsoft.SharePoint.ClientSideComponent.SPClientSideComponentMetadata'.

 

image.png

 

Any suggestions?

 

I'm also unable to rollback the solution to any previously working version as I receive the same error there as well.

6 Replies

Could it be that you are using an older version of the SPFx as a base for this app?

best response confirmed by Cameron Sibbald (Occasional Contributor)
Solution

That was a bug that got out - we believe it should be working now.  Can you let us know if you are still running into the issue?

Yes - the middle problem was the same thing.  It was fixed in that thread, but wanted to make sure you weren't hitting a different issue with a similar symptom.

Yup. I saw that one yesterday but started this thread because I was getting a different error message.
It's fixed now for me as well. Thanks Pat.