Rename labels on taks

New Contributor

Hi all, happy new year.


I can not rename labels from a task in Planner, they always came back to default. Any help?



12 Replies
Indeed you cannot rename labels in Planner, what you can do is just add Tags to your mean you are not able to add tags?
Thanks Juan, I can not rename tags, I type a new name but it just not 'save', and also not see how to add tags. I´m a brand new user and appreciate any help. Regards.

I get the same problem.  According to the documentation, this should be possible, but every time I rename a label, it just goes back to default (Label 1, Label 2 etc).



It looks like you can rename labels, but only if they aren't used! If they are associated with any tasks, they revert to the previous name as noted above.

OK, it's not quite that simple - it depends where in the app you are (I'm using the web app). If you are in the board view, group by labels, and trying to change the labels at the head of the columns then what I said above applies. However, if you are in a task, you can click on the coloured blog on the top right border of the task and from there you can change the label whether it is applied to tasks or not.

I had the same issue, when trying to rename labels from within Planner.

I tried several times, but they always reverted to default Label 1, 2 etc

But when I tried from within Teams (Planner tab), it worked and the labels were saved.


Not sure if the issue comes from the way the plan was created: From Teams, vs from Planner and attached in Teams

@Richard Griffiths This does work. Note that you need to open a task and look at the details of it. Then on the right-hand side you will see the colours representing the labels. When you hoover your mouse pointer over a label, it expands and you are able to give the label a new name.

@Juan Carlos González Martín 


How do I add tags to the labels?  This is my first day in teams Planner so I am still making my way around the GUI.  Thanks.

It looks like it doesn't work, but if you hover over the label tab and just start typing, it will accept the new label

I'm not even able to edit a label - i'm on Office for Mac.


I didn't create the teams/ workspaces, but I am designated owner of several and haven't been able to edit any labels. 


Is this a mac issue?

@Rogerio Ernesto I was having the same problem.  Every time I changed a label it would revert back to the original.  I know it sounds dumb, but I refreshed my browser page and it was fixed.