Missing OneDrive context menu in windows 10

Copper Contributor

Hi, I'm missing the context menu on synced OneDrive for Business files. The icons on the cloud status are visible, but in the right-click menu I have no section on OneDrive. 

So no chance of changing the status to "Always Keep on device".

Is there a registry key missing or what can I do to get it back?

Ondrive client works otherwise without any problems!




55 Replies

@BallsOfSteel420 This simple solution worked for me; thank you. If I may, it is even simpler; you don't have to uninstall OneDrive at all. Just quit the running instance, then run the command 

# I'm using PowerShell Core
.\OneDriveSetup.exe /AllUsers


@Oliver Kuhl 

I solved this by finding "Edit group policy" from my start menu.
Then I clicked through Computer Configuration -> Windows Settings -> Security Options -> Local Policy -> Security Options.

Next, I enabled a few of the 'User Account controls' which were disabled and then restarted my PC. Can't say for sure which setting did the trick but it now seems to work.

I have all on the following enabled:
Admin Approval Mode for the Built-in Administrator account

Detect application installations and prompt for elevation

Only elevate UIAccess applications in Admin Approval Mode

Switch to the secure desktop when prompting for elevation

Virtualize file and registry write failures to per-user locations


Don't forget to restart the computer after that and then check OneDrive to see if it has worked.


Once a day I've found I can't enter to any MS service of my BUSINESS account with any ID, incl. OnDrive cloud storage where I still have a lot of working files like contracts, drawing, notes etc. And there's ONLY working files as some of the files and directories are shared with partners I seeked technical assistance but get the cloudy response: "We examine new government mandates thoroughly to be certain our compliance does not impact a customer beyond what is required by law. ****** has been identified as subject to mandates and we're obliged by law to take action. Our legal team is required to follow a government mandate process to identify and suspend service. If you require any further information on this I recommend you seek external counsel. Further calls to other agents will be met with the same response" With no further explanation nor ability to get my files back. Any idea how I can recover my files which are stolen by this way? Reason of the action could be also intersting but I'm not sure it's reasonable to use the OneDrive cloud storage anymore for anybody who need cloud storage for essential files used for work or business. Probably the reason is some new goverment regulation in Russia or US but I'm not sure the immediate blocking w/o ability to backup my work is not an excessive action just in case safety been affected

@BallsOfSteel420 this fixed it for me!  thank you!!!!  people, follow this instruction


Brilliant! I was tearing my hair out by the roots but this worked 100%. Finally. Thank you so much. I never would have thought of adjusting my UAC up and back. Holy cow. It's a miracle!

Changing UAC settings worked for me - thanks @Jabiru 
Both One Drives were working and syncing (personal and business), but the context menus to choose online/offline etc were missing.
Ran User Account Settings, and changed from Never Notify (must have had it on for some development work) to a higher setting and context menu is back.

This solution is working perfectly for me. Thank you.
Awesome! Glad it helped you Komgrit.
Its an annoying problem, glad you got it sorted following Jabiru advice.
Awesome mate. Hopefully MS will fix this properly one day.

@clren, that solution worked for me as well



This is the solution.

You don't even have to uninstall your existing installation. I had this issue and was able to solve it following @BentleyC 's suggestion.

Worked for me! Installed with OneDriveSetup.exe /allusers

@Oliver Kuhl 


I believe the issue that you are facing is that, you are suddenly missing "Share" OneDrive from your context menu, then follow these steps:

1. Go to C:\Program Files\Microsoft OneDrive
2. Look for latest installation folder, eg. I had it in "22.002.0103.0004_1"
3. Inside the folder look for "OneDriveSetup.exe"
4. If you find the file, then right click inside the folder and click "Open in Windows Terminal" or "Open Command Prompt"
5. Type command "OneDriveSetup.exe /allusers" and press enter.
This is how the installer will open and then will finish the activity.
See image >>

6. Now go back to your folder in Explorer, and do right-click to see the OneDrive share context menu. 

Hope this helps others? Please leave comments.

Enabling UAC settings worked for me, the user had Windows 19042 XXX version, Once UAC enabled and Pc rebooted, the context menu is back!
This is what helped us too.
I see now Microsoft is installing it this way in Windows 10.
I never could understand the logic behind installing for local user when the config stuff can go to AppData.