Unable to install Exchange Online PowerShell Module supports multi-factor authentication

Occasional Contributor

I go to the EAC, hybrid and click Configure and all I get is a quick flash of "Running Security Scan" and then...nothing.

11 Replies
best response confirmed by Brian Reid (MVP)

Use IE, other browsers don't support the click-once functionality used with the installer. Or require add-ins/additional configuration.

Shhh, don't even mention that thing :)

Thanks for your replay.


 i tried in IE/Chrom/Mozila but no luck

Thanks for the replay.

it doesn't  work on Edge  as well

I had this issue with Chrome. Changed to IE and it worked.

Please use internet explorer, other browsers are not supportive. 

You can use the Microsoft.Exchange.Management.ExoPowershellModule that is located on the PowerShell Gallery

Install-Module -Name Microsoft.Exchange.Management.ExoPowershellModule -Scope AllUsers


Install-Module -Name Microsoft.Exchange.Management.ExoPowershellModule -Scope CurrentIUser

There is a later version v2, called ExchangeOnlineManagement


Install-Module -Name ExchangeOnlineManagement -Repository PSGallery -Scope AllUsers -MinimumVersion 0.3374.9 -AllowClobber -Confirm:$false -Force -AcceptLicense




Install-Module -Name ExchangeOnlineManagement -Repository PSGallery -Scope CurrentUser -MinimumVersion 0.3374.9 -AllowClobber -Confirm:$false -Force -AcceptLicense


use Connect-ExchangeOnline to connect and trigger MFA



@Vasil Michev 


Question, now that IE is officially dead, how do we transition this functionality to the new Edge?  

Tried running it recently, no go, still have to use IE.