NOTE: This might not be a PSF issue but one that needs to be solved elsewhere in the system?


Repackaged Blender 2.7.6 x64 using the MPT and the PSF for File Redirection so that the app can see its config file.  The app fails before getting to that point and running a ProcessMonitor trace I think I see the problem.


At one point the app seems to be calling GetShortPathNameW against "C:\Program Files\WindowsApps\[{PackageName}]\2.76\datafiles\…".  The issue is that the WindowsApps (which is 9 characters long) has NO shortname.  So somehow the app then tries to open "C:\Progra~1\Window~1\…" which is actually a different folder!


Screen shot attached. #1 is the call through GetShortPathNameW, #2 is the failed call using the return information from GetShortPathW..



4 Replies

@Tim ManganHi Tim,

I saw this kind of issues as well. Some applications might work with a workaround. Try this:

invoke a process inside the Namespace Invoke-CommandInDesktopPackage


Sample for FreeCommander
Invoke-CommandInDesktopPackage -PackageFamilyName FreeCommanderXE-32_dcsc6zw6cdwca -AppId "FREECOMMANDER" -Command cmd.exe


Inside try to execute the app from within the native path i.e.:

C:\program files (x86)\...

or the 8.3 path


This helps quite often and can be solved with a standard wrapper - or psf in the future.

I'll try Blender myself later the week.




@Johannes Freundorfer Thanks.  But we are repacking a vendor installer into MSIX, so we don't have access to the source code.  ...and it's probably unmanaged code anyway... 



We made a test with Blender in Advanced Installer 15.9 ( I included a link for you to get this RC) and the MSIX packaged app runs ok.


Are we missing something from your test?


From here you can get the package and project built with AI 15.9.

@Bogdan Mitrache


Training folks this week so I won't be able to look at it (I'm often brave about updating software on the fly but I'd rather show these folks the 15.6 I know on our first training class on MSIX).  My package was made using the MPT, so maybe you are doing some great magic, or maybe it is the version I used (2.76b) or how I test.  I can privately send you my package and the installer for that version in the interim.