Failed with error 0x8000FFFF

Copper Contributor



Every time when I try to install this particular package, I get this error.


App installation failed with error message: Deployment Add operation with target volume C: on Package com.weareinsite.sequenceapp_1.2.17.0_neutral_~_c70m4x1tbaqpp from: (InSite.UAEX.SequenceApp_1.2.17.0_x86_x64_arm.msixbundle) failed with error 0x8000FFFF. See for help diagnosing app deployment


Anyone who knows the solution please assist.

4 Replies

Hi @prashanthkumar 


We've built a free MSIX Troubleshooter tool to help investigate such situations. Give it a try if you have the time.


It is a young tool and we continue to improve it, so any feedback is more than welcome. You can also email me with the package at bogdan at advancedinstaller dot com, so we can take a closer look if the tool doesn't help.




Had the exact same error message when attempting to sideload a packaged WinUI 3 app on Windows 11. It worked as soon as I installed through the MSIX Troubleshooter as suggested by @Bogdan Mitrache. I haven't hit the error with this particular app since after, even when using the regular App Installer.
None of the suggested locations of the Event Viewer were any helpful beyond that error message, The only additional intel I could find was "The last successful state reached was UndockedDEHEvaluated. Failure occurred before reaching the next state Approved. hr: 0x8000FFFF".
I had a troublesome MSIX installer that crashed always with this error. Then I downloaded the MSIX Troubleshooter and ran the install with it. For some reason the install went fine without error. Also after this, the normal MSIX install started working fine.
I am not sure what is causing this, it seems that the Troubleshooter way of installing is clearing some data or file that is causing the errors.
Anyway this tool gives a great visibility into the MSIX and the installation process.
Thanks for a very useful tool.