Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Error MSIX package version >= 3000.851.1712.0

Copper Contributor

Error MSIX package version >= 3000.851.1712.0 after doing some terminal admin thing still pops up on the screeen.Error.png

8 Replies

This has something to do with McAfee, possibly something in a recent update.  My McAfee on my PC recommended I reinstall the app because it wasn't updating.  I did the reinstall, and now whenever I start my PC, I get this same error pop up.  I have not tried clicking yes on the pop up because I read on the MS community that doing so did not solve the problem for other people.  Another user on MS community posted the info below about contacting McAfee.  (see quote)  She said it fixed the MSIX problem for her, but another person who replied said reinstalling McAfee did not work for them.

 

"Hi I had this issue and it is a McAfee problem. I contacted them via their chat facility. It is a global problem they said. The technician told me to fix it I needed to uninstall McAfee and then reinstall it."

 

  @Quinne20 

Hi @Quinne20 
Can you please share the application/package that you are trying to use and what version of Windows are you running it on?

 

@LostSoulx Did uninstalling and reinstalling McAfee help solve the issue?

Thanks,
Fiza Azmi
PM, MSIX 

@fizaazmi 

 

Hi, sorry to hijack this thread but no-one has replied to you and I am suffering the same problem.  I have downloaded Windows App Runtime version 1.4 (and also version 1.3 on another machine).  I am running Windows 10 (automatic updates on).

Just to note after running the file windowsappruntimeinstall-x64 (Windows App Runtime version 1.4) I cannot view it as installed within programmes and features or Installed Updates.

Below is the version of McAfee.  Thanks Nigel

Nigelcp_0-1703070605048.png

 

@Nigelcp Windows App Runtime is a framework package and doesn't have any application. That's the reason you do not see it in programmes and features or Installed Updates.

You can use below powershell command to view the install status. 

Get-AppxPackage -Name *WinAppRuntime*

@ravishroshan Oh that would make sense thanks.  I'm still getting the aforementioned error message when logging into windows though.  Any thoughts?

 

Have you managed to fix this yet?

The required framework package is *likely* on your system, but not currently installed for the user.

 

To verify if the user has the package use this command:

   Get-AppXPackage -Name "Microsoft.WIndowsAppRuntime*"

 

To check what's available on your system, use elevation and try

   Get-AppXPackage -Name "Microsoft.WindowsAppRuntime*" -allusers

 

You should see packages ending in 1.3 and probably 1.4 (plus maybe a .CBS), and both x86 and x64 packages for the version.

 

Manually, you can then just run Add-AppXPackage for the version you need added to the user.

 

Packages needing that runtime can trigger the automatic installation of the runtime's framework package by including a dependency in the AppXManifest file and avoid the user being bothered by this.

@TIMOTHY MANGAN 

 

thanks I'll have a look when I get the chance.  Having a Google it looks like this is a common problem with McAfee which they don't want to try and fix.

 

Thanks again

 

Nigel