Teams setup with multiple domains in tenant

New Contributor

Hi everyone,


we have a Tenant with multiple added domains.

- (default)




Users are synched from On-Prem to AAD.

They show up in the AAD directory with proxy adresses like that;


User Type A:



User Type B:



Both types of users have assigned E3 licenses.


So far... everything ok and as expected...


But now...

User Type B cannot search external users in MS Teams.

After I've checked a few things, I could find a difference in the users list in the MS Teams admin panel.

User Type A: Directory status "Online"

User Type B: Directory status "Unknown"

(there is also a User Type C: Directory status "Unlicensed")


For me it seems like a missing (license?)-connection from the tenant-user to the teams-user?


Any ideas or recommendations to fix it?




3 Replies

@trepach if I had to guess, and just spit balling here, I suspect the whole domain probably has that issue. I would suspect they are in Island mode and missing DNS entries for Skype for Business. You should try switching the user to teams only mode, or the domain to teams only coexistence mode, or just adding the public Skype4Business DNS entries for the domain.


Did you ever found more information on this issue? I'm seeing this as well in a tenant with multiple domains/forests. And I have licensed users from the other forest sometimes appearing as directory status "unknown" in the Teams admin center. This is also preventing them from being found and added to Teams. The rest of the web says to turn off Islands mode but that's all deprecated now.

Did you find anything in your journey?
Hi there,

yes - after a few attemps and try and error, we've found a solution.

Following steps were needed;
- check and clean-up DNS-settings on your domain (i think you already did and it's fine)
- change Teams-mode to 'TeamsOnly' (i think you already did and it's fine)

But after that, some users still had the same issue.

Then the solution was as follows:
- deallocate and then allocate again the E3 license on the affected user(s) (it seems for me, the SIP-registration was new made during this step)
- additionaly we had to change the "TeamsUpdgrade" mode on the (existing) affected users to 'TeamsOnly' manually with PowerShell (that means, turning off the islands mode generally had no effect to existing users maybe)

Use Get-CsTeamsUpgradePolicy and Grant-CsTeamsUpgradePolicy to check and adapt.

After all that... everything worked as expected.

Further helpful informations;

Let me know, if this also worked for you...