No Outlook calendar Teams invitation possible after upgrade to Teams 2.0

Copper Contributor

Dear all,


we have our own tenant for MS Teams and since the update to Teams 2.0 from 1.0, users of Microsoft Outlook have problems with the Teams Add-in:


1. Problem 1: New invitiations to Teams meetings are not possible. When you create a new calendar entry and click on "Teams Meeting", nothing happens, the usual "Teams block" including a link to the Teams meeting doesn not appear, the decription field of the calendar entry will stay empty.


2. Problem 2: Existing Teams meeting cannot be changed. If you try to change an existing Teams meeting, that has been successfully create before the upgrade to Teams 2.0, e.g. you try to change date/time and click on "Send update", you get the error message "To schedula a Teams meeting, make sure you're signed in to Teams". 


Everyhting elese is wokring for the users, they can start Teams 2.0 (or switch back to 1.0) and use any other function in the Teams client.


We have Exchange OnPrem and no ExchangeHybrid. Under Teams 1.0 everyhting worked fine including Microsoft Outlook. Windows 10 and Office 2016 are on the latest patch level, the Teams Add-in is registered and active in Outlook, we also tried to reinstall Teams, delte the Teams cache, re-register the TeamsAddin-DLL.


Any idea?


2 Replies


Is the Teams add-in disabled? In the desktop version of Outlook, go to File > Options > Add-ins (far left pane) > and in the drop-down menu for Manage: select Disabled Items and then select the Go... button. Do you see a Teams add-in listed in that section? If you do, select it and then select the Enable button.

Perhaps install Teams classic app back onto a device to see if it makes an impact? Microsoft still offers (at least currently) the classic installation of Teams classic. You can access it directly by going to

In case the link doesn't work for the future, you can (currently) navigate there manually by going to, selecting Download Teams in the upper right corner, scroll down past the initial download option (which is for Teams 2.0) and look at the FAQ collapsible options. Expand the answer to the What does this mean for the classic Teams customers? question, and there will be a Download the class Teams app > hyperlink available for you to click. 

For a PC that we were testing Teams 2.0 (on a GCC tenant - so I can't promise any of this will work) we had uninstalled the original Teams application and only had Teams 2.0 installed. Once we reinstalled the Teams classic app the Add-In functionality was restored in the Outlook desktop application. I believe we did have to select "Swap to classic Teams" (or something around those lines) after installing and launching Teams classic, for the add-in to start working again, but afterwards we could swap back to Teams 2.0 and the add-in was still using the classic Teams. (Or I'm guessing it is using Teams classic for the Outlook add-in at least. I may also have been impatient and reverted back to classic Teams when we didn't need to after launching the Teams classic app - since you can use Teams 2.0 after the add-in functionality was restored.)


Matthew Klonizchii

Please note that I am not a Microsoft employee, vendor, or partner. I don't intend to represent Microsoft in any capacity or supplant their own technical support channels available to their consumers. 

@Matthew_Klonizchii : 


- The Teams Add-in was enabled in Outlook when the error occurred

- Uninstalling Teams 2.0 + 1.0, delöeting the cache, downloading Teams 1.0 and reinstalling it "solved" the problem -> but it works only under Teams 1.0, if you switch to 2.0, the error is back again