Microsoft Teams for Ubuntu 20.04 will not start

Regular Visitor

I am trying to get the official MS Teams application to run on my Ubuntu 20.04 machine. No matter how I install it, it will not display any sort of window when ran normally (i.e. clicking the icon in Applications, running teams if installed with apt, or running 'snap run teams' if installed with snap).

When I run snap run teams, I get this error: 2022/02/18 10:15:43.002794 cmd_run.go:1039: WARNING: cannot start document portal: Expected portal at "/run/user/197001104/doc", got "/home/username/.cache/doc"

When installed with apt and I run 'teams', I get no output and the process ends immediately.

The only way I am ever able to get a window to display is if I install with snap, 'snap install teams', then run it with 'snap run --trace-exec teams'. Then it works as expected.

When not ran with 'snap run --trace-exec teams', I can see several processes running when I check 'ps aux | grep teams'. These never close themselves and require a 'kill <PID>' to exit.

I have tried the following versions with apt/dpkg:

1.4.00.26453
1.3.00.16851
1.2.00.32451

and the version snap installs is: 1.4.00.26453

I have tried uninstalling, reinstalling, clearing my cache using the following script, and any combination of the three. https://gist.github.com/mrcomoraes/c83a2745ef8b73f9530f2ec0433772b7

~/.config/Microsoft/Microsoft Teams/logs/teams-startup.log

A JavaScript error occurred in the main process
Uncaught Exception:
Error: /usr/share/teams/resources/app.asar.unpacked/node_modules/native-utils/build/Release/native-utils.node: undefined symbol: _ZN5Utils32IsQuietHourOrDoNotDisturbEnabledEv
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:143:31)
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:722:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:152:18)
    at Module.load (internal/modules/cjs/loader.js:602:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:541:12)
    at Function.Module._load (internal/modules/cjs/loader.js:533:3)
    at Module.require (internal/modules/cjs/loader.js:640:17)
    at require (/usr/share/teams/resources/app.asar/external/v8-compile-cache/v8-compile-cache.js:173:28)
    at Object.<anonymous> (/usr/share/teams/resources/app.asar/node_modules/native-utils/index.js:1:173)
    at Object.<anonymous> (/usr/share/teams/resources/app.asar/node_modules/native-utils/index.js:3:3)

snap version

snap    2.54.3+20.04.1
snapd   2.54.3+20.04.1
series  16
ubuntu  20.04
kernel  5.13.0-28-generic

If any other info is needed or would be useful for troubleshooting, please let me know. I am all out of ideas.

2 Replies

@Josh_R_bcf, I'm not sure if this is related, but my MS Teams wasn't showing up on a fresh install of Ubuntu. I edited ~/.config/Microsoft/Microsoft Teams/desktop-config.json and changed "disableGpu":true (it is false by default). Hope this helps!

Thanks this edit from false to true worked for me!