SOLVED

Having issues signing into a yealink teams room panel

Copper Contributor

I've read the doco on the android teams devices being logged out, but I don't think that is the issue here.

 

One of the panels was logged out and when I go and try and log in again via the microsoft.com/devicelogin I get the following message after entering the login details - "Signing out... You're already signed in with another account.  Sign out and try again."

 

I can see in azure saying it was a successful login, and no failures.

 

I've tried rebooting and just then a factory reset but I get the same message.  I've also tried logging in via the teams admin portal, the device login page and via the device it self by entering in the username and password directly.  All give the same error message. 

 

There's no logout button, when the device starts it goes to the "You'll need to sign in to use this app" screen.

 

Any ideas?

33 Replies
Glad I could be of help!
Yes, after the updates to the ROOM SYSTEMS (A20+CPT18), the systems are working with Basic. The issue is the ROOM PANEL not working with the Basic license. Like i said i have had that option tick for about 5 years now. I what to try Teams Shard Devices license but not yes, I wait for the Standard one to expire completely :) and then start other 30 days trail :P. Tnx guys.
Works fine, thanks very much.
This was the fix for me too, A20. just updated firmware and suddenly getting error in OP. All sorted with your fix, thanks!

This solution worked today for a Yealink Room Panel (android based, with Teams software) even though Intune is also not setup on the tenant with the Teams Pro license on it for the user account for the device. Tried all the same things first - factory reset, etc. Thank you for solution - would have not guessed this setting change on my own. Weirdly, client says Room Panel Teams login problem started a couple of days ago, when they enabled, and then disabled, MFA for all Azure user accounts, except they say that they excluded the user accounts for the four Teams devices with Pro licenses. 

After a couple hours of trying various solutions, this fixed the issue for me. Was stuck with my admin panel showing "Signed out" as the active user and was unable to sign in since "another account is already signed in". Thankfully this little check box solved the problem and my conference room is back in business.

@dunhamj

@ChrisCurtisIT 

 

Hi,

 

i am resolving same issue in my company tenant. My question is - when we have all other devices onboarded using Android Enterprise (BYOD), will NOT checking this box "Use device administrator to manage devices." fck my devices? We have over 2K of them, so it would be unfortunate.

 

Thank you.

Hi
Having the log in issues with my Yealink on Windows 10.
Any suggestion what to do to sign in on a Windows device?
Team Room Pro license is assigned. I can log in with the resource credentials on other devices. Just no an my Yealink MCore Mini-PC mit Yealink MTouch II.
sorry it's a Windows 11 IoT
Is there any error message? Or is there any info in Azure log ?

@RadekPro 

no, just the message that device could not log in to Teams.

Azure shows no logins.

Account does have access to Azure, checked with login on private Edge.

Device has network, checked with browser on device.

No Conditional Access is set.

@Robin160 doest it work even your intune havent configured? Just tick the box?

 

I have a case now, My client havent really configured the intune. The Panel keep showing the you've already sign in issue. I tried the Crestron Demo account and it works, obviously its the account that is having the issue. 

 

So on this case, can we just tick the box eventough the intune is not using/not configured yet?

 

Thanks!

Aze

this is the reals solution

@Acasey80 

 

I ran into a similar issue, instead of changing the licencing for Teams, I started a full factory reset, and changed the preferred mode to 'device mode'.

 

From there I was able to use the hardware's Microphone and Camera whist still being able to share my screen regardless of what 'video call' software I was using.