SOLVED

Graph API error message "No Team found with Group id"

%3CLINGO-SUB%20id%3D%22lingo-sub-1438855%22%20slang%3D%22en-US%22%3EGraph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1438855%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20get%20an%20error%20message%20every%20time%20I%20run%20%3CEM%3EGET%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fteams%2F%7Bteam-id%7D%2FinstalledApps%3F%24expand%3DteamsAppDefinition%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fteams%2F%7Bteam-id%7D%2FinstalledApps%3F%24expand%3DteamsAppDefinition%3C%2FA%3E%26nbsp%3B%3C%2FEM%3EI%20get%20the%20error%20message%20%22No%20Team%20found%20with%20Group%20id.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20also%20tried%20using%20the%20following%20and%20got%20the%20same%20error%20message%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%24uri%20%3D%20('%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fgroups%3F%24select%3Did%2Cdisplayname%2CresourceProvisioningOptions%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fgroups%3F%24select%3Did%2Cdisplayname%2CresourceProvisioningOptions%3C%2FA%3E')%3CBR%20%2F%3E%24teams%20%3D%20(Invoke-RestMethod%20-Method%20Get%20-Uri%20%24uri%20-Headers%20%24token).Value%20%23%7C%20Where-Object%20%7B%24_.resourceProvisioningOptions%20-contains%20'Team'%7D%3C%2FP%3E%3CP%3Eforeach%20(%24team%20in%20%24teams)%20%7B%3CBR%20%2F%3E%23%20Get%20the%20General%20Channel%20properties%3CBR%20%2F%3E%24channel%20%3D%20(Invoke-RestMethod%20-Method%20Get%20-Uri%20(%22%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fteams%2F%24(%24team.ID)%2Fchannels%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fteams%2F%24(%24team.ID)%2Fchannels%3C%2FA%3E%22%20%2B%20'%3F%24filter%3DDisplayName%20eq%20'%20%2B%20%22'General'%22)%20-Headers%20%24token).Value%3CBR%20%2F%3E%7D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20error%20screenshot%20is%20below.%20I'm%20getting%20this%20in%20PowerShell%20as%20well%20as%20the%20Graph%20Explorer.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20data-unlink%3D%22true%22%3EReading%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fknown-issues%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehere%3C%2FA%3E%2C%26nbsp%3Bit%20does%20look%20like%20there's%20a%20known%20issue%20with%20pulling%20list%20of%20teams%2C%20is%20this%20what%20could%20be%20causing%20this%3F%3C%2FP%3E%3CP%20data-unlink%3D%22true%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20data-unlink%3D%22true%22%3EThank%20you!%3C%2FP%3E%3CP%20data-unlink%3D%22true%22%3EPam%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-06-03_10-52-50.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F196333i57C14508424D018F%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%222020-06-03_10-52-50.jpg%22%20alt%3D%222020-06-03_10-52-50.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-06-03_12-29-50.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F196334iE1C28B2C7B358D90%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%222020-06-03_12-29-50.jpg%22%20alt%3D%222020-06-03_12-29-50.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-06-03_12-34-13.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F196331i48A819AE1A852251%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%222020-06-03_12-34-13.jpg%22%20alt%3D%222020-06-03_12-34-13.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-06-03_19-33-11.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F196332i0ACD701281147376%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%222020-06-03_19-33-11.jpg%22%20alt%3D%222020-06-03_19-33-11.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%E2%80%83%E2%80%83%E2%80%83%E2%80%83%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1438855%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EError%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EGraph%20API%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENotfound%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1439100%22%20slang%3D%22en-US%22%3ERe%3A%20Graph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1439100%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F687904%22%20target%3D%22_blank%22%3E%40pammnd%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20figured%20this%20out.%20Please%20disregard.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1677070%22%20slang%3D%22en-US%22%3ERe%3A%20Graph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1677070%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F687904%22%20target%3D%22_blank%22%3E%40pammnd%3C%2FA%3E%26nbsp%3BPlease%20share%20what%20you%20figured%20out%20%3A)%3C%2Fimg%3E%20I've%20got%20the%20same%20error.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1747116%22%20slang%3D%22en-US%22%3ERe%3A%20Graph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1747116%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F687904%22%20target%3D%22_blank%22%3E%40pammnd%3C%2FA%3EWhat%20was%20your%20solution%20to%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1747579%22%20slang%3D%22en-US%22%3ERe%3A%20Graph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1747579%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F821038%22%20target%3D%22_blank%22%3E%40zachatzix%3C%2FA%3E%26nbsp%3BSorry%20for%20taking%20so%20long%20to%20reply.%20In%20my%20case%20it%20was%20user%20error.%20I%20forgot%20to%20remove%20the%20brackets.%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Ffacepalm_40x40.gif%22%20alt%3D%22%3Afacepalm%3A%22%20title%3D%22%3Afacepalm%3A%22%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1747595%22%20slang%3D%22en-US%22%3ERe%3A%20Graph%20API%20error%20message%20%22No%20Team%20found%20with%20Group%20id%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1747595%22%20slang%3D%22en-US%22%3ESorry%20for%20the%20late%20reply.%20It%20was%20user%20error%20in%20my%20case.%20I%20forgot%20to%20remove%20the%20brackets.%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hello,

 

I get an error message every time I run GET https://graph.microsoft.com/v1.0/teams/{team-id}/installedApps?$expand=teamsAppDefinition I get the error message "No Team found with Group id."

 

I've also tried using the following and got the same error message:

 

$uri = ('https://graph.microsoft.com/v1.0/groups?$select=id,displayname,resourceProvisioningOptions')
$teams = (Invoke-RestMethod -Method Get -Uri $uri -Headers $token).Value #| Where-Object {$_.resourceProvisioningOptions -contains 'Team'}

foreach ($team in $teams) {
# Get the General Channel properties
$channel = (Invoke-RestMethod -Method Get -Uri ("https://graph.microsoft.com/v1.0/teams/$($team.ID)/channels" + '?$filter=DisplayName eq ' + "'General'") -Headers $token).Value
}

 

The error screenshot is below. I'm getting this in PowerShell as well as the Graph Explorer.

 

Reading here, it does look like there's a known issue with pulling list of teams, is this what could be causing this?

 

Thank you!

Pam

2020-06-03_10-52-50.jpg

2020-06-03_12-29-50.jpg

2020-06-03_12-34-13.jpg

2020-06-03_19-33-11.jpg

    

5 Replies
Highlighted
Best Response confirmed by pammnd (Occasional Contributor)
Solution

@pammnd 

I figured this out. Please disregard.

Highlighted

@pammnd Please share what you figured out :) I've got the same error.

Highlighted

@pammndWhat was your solution to this?

Highlighted

@zachatzix Sorry for taking so long to reply. In my case it was user error. I forgot to remove the brackets.:facepalm:

Highlighted
Sorry for the late reply. It was user error in my case. I forgot to remove the brackets.