Cannot add custom app to the Teams Sidebar in Teams

Occasional Contributor
Hello everyone,
I’d like to thank you in advance for your replies and assistance. I ready do greatly appreciate it.

I have an issue when trying to add an app within Teams. Inside Microsoft Teams, in the Teams sidebar on the left, there are the 3 dots which allow a user to add more apps within Teams. When clicking these dots and adding for example the Microsoft Forms app, I search for the app, it shows up, I choose it, and then there’s an “Add” button (with its own drop-down menu) where I then have the option to add it to either a team, a chart, or a meeting.

The problem I run into is that when trying to add a custom App (an app/SharePoint hub site that was built for our organization) within Teams, I search for the app, it is found, I click it, but now there is no “Add” button.

The custom app is not blocked (allowed) in the Microsoft Teams Admin Center, and employees could previously add this app within Teams and pin it to the Teams sidebar without a problem. But that is no longer possible since the Add button is gone. In the Org-Setting the third party apps are allowed and custom apps are also allowed and not blocked.

Any idea?

Thx a Million.
1 Reply
Hi, sounds strange that this has worked previously and now it doesn't. Anything that has changed in your environment when it comes to the policies? I would probably walk trough the settings and perhaps do it all over if everything looks ok, or open up a support ticket with Microsoft.