'We're having trouble updating your team. Please try again later.' when trying to update team avatar

Copper Contributor

Hello there,


I've been trying to update my team's avatars to make them more easily identifiable for a couple of months now but persistently receive this message when I try in-app or online:


We're having trouble updating your team. Please try again later.


I've tried on different networks/ devices and nothing seems to make a difference.

Any help would be hugely appreciated!

12 Replies

We're also seeing this error for a few Teams on our tenant when trying to rename the Team. Not sure what the issue might be.  



Jump forward to August 2022. We are experiencing this issue on our Education Tenant. Are others seeing the same? Can you update a Team's Icon? Is it just us or a wider issue?

@Chris_Laycock We're also experiencing this issue with our Teams. I checked with the creator of that particular team, who is an owner and an admin, and they were not able to make that change. I'm able to create a new team and then change the avatar. Don't think its a permissions issue, I'm a global admin. 

@zeezee003 - thanks for your response.  I am the owner of the Team, have also checked with our tenant global admin, same error for them 'We're having trouble updating your team. Please try again later.'


As a workaround I was able to use the mobile (Android) Teams App to edit the Team and upload a new Teams avatar from there.

It is then reflected in both the Teams desktop App and Browser


We are having the same issue. I wish they would fix!
This has corrected itself in our tenant. It took around 4 to 5 days.

@Chris_Laycock For one team, this is no longer an issue. For another team, this issue persists. Strange!

We are having the exact same problem. Anybody got a solution yet ? 

It's failing for us again too. It works 2 days out of 7? The mobile App is still a solution if setting the Team icon is an urgent one.
There doesn't seem to be an 'Action' within the Teams connector in Power Automate to update the Teams Icon, not sure if anyone else has any hints?


There is a Powershell command: Set-TeamPicture (MicrosoftTeamsPowerShell) | Microsoft Docs
Can anybody experiencing the issue see if the powershell script works?


We have the same issue.

I found a work around:
If you edit the name of the team for exemple you add "test" at the end of the team's name and if you change the avatar it works.

Very strange all our teams are impacted.