Unable to login to view videos through OneNote

Copper Contributor

I've copied the URL directly from the "share" button on the videos I've uploaded to Stream and put them in my Class Notebook. Every video prompts the user to log in and they are immediately redirected to a page that indicates that the page does not exist. Is this a known issue or am I doing something wrong? This has happened on 8 different videos today.



6 Replies

A few questions -

1.) Do the users who are trying to view the video have Stream/Office 365 licences? If so is stream enabled within that licence?

2.) Have you given the users permissions over the video? If they don’t have permissions they won’t be able to see it

Hope that helps. Let me know how it goes

Best, Chris

@Christopher Hoard 

Stream is a part of our Microsoft for Education package and the permissions are currently set for anyone within our organization. The error that was generated came from me checking to see if the videos would display in the NoteBook. So the error was caused when I clicked on the link to sign in and I definitely have permission to see my own videos! 


I did discover that the hyperlink that generates above the video when it embeds on the NoteBook page does work. So you can click the hyperlink and go to the video but you cannot view the video on the NoteBook page without generating that error.

I would raise this to Microsoft Support. It could be a bug. You would imagine that stream videos ought to be viewable in the Notebook, but I am not 100% sure this is the case. Considering they have just been introduced in Forms and Powerapps, it may be a case that they are currently working on it and whereas links work, it may not be currently supported

Best, Chris


Hi there! Are you using the OneNote Win32 app or the UWP? If you're using Win32 unfortunatel you'll need to manually sign in once before the sign in is cached in your notebook. I'm surprised to hear that signing in takes you to a page that doesn't exist - that's the unexpected part. Could you send me a screencap/the link it's navigating you to? Feel free to email me directly at saraje@microsoft.com


@alex_loves_historyI have noticed the exact same issue in OneNote App on my Mac. It works in the browser version of OneNote and seems to work in the Windows version of OneNote App. This seems to be a Mac App issue.

@Christopher Hoard 

I have the exact same problem today, Nov 3rd, 2021. I published a video on Stream in a team channel a couple of days ago. I also pasted a link to the video in a page in the Class Notebook. That day, everything worked. Today it doesn't. More specifically:

- I can see the video in Stream in the browser

- I can see the video in the OneNote Windows App 

- In Teams -> Class Notebook -> page with video there is a gray rectangle instead of the video, which  says "To see this content, sign in. New to Microsoft Stream? Sign up." 


I tried signing out of the Teams app and signing back in, nothing changed. The problem is within Teams, but I can't figure out what it is.


EDIT: And here I am to eat my own words. After a bit of tinkering, I clicked the "globe icon" in the upper right corner of OneNote Class notebook in Teams. This opened OneNote in the browser. There (in the browser) I had to log in again into OneNote, and miraculously OneNote inside Teams started working.


IMHO this whole authentication mechanism in Teams is complicated with many possible weak links. I know a bit about computers and can usually wiggle out of trouble, but my colleagues are turned away from Teams as soon as something like this happens. They have a choice between Teams and Google classroom and guess which one they choose when Teams has a hiccup? Don't get me wrong, I use Teams and wholeheartedly recommend it, it's just that it's a conglomerate of many complex and intricate parts.