'Something went wrong' message when joining Windows 10 Pro PCs to AAD

Copper Contributor

I have previously added 12 PCs to an AAD domain, but I get this message when trying to add any more (tried several machines). I have tried using a different global admin account.


I logged this with Office 365 support and eventually got escalated to Azure support and was told that this feature is in Preview and I can't get support, but to try the Forums...


I have looked to see if I can perform a AAD join using PowerShell in the hope of getting a more detailed error message but from what I have found so far there is no command for this.


Any suggestions on the next step appreciated :)

3 Replies
I'm wondering if the issue is the amount of devices registered to the account is hitting a limit somewhere else (like Intune).
You shouldn't actually need to be a Global Admin to join a Windows 10 PC to an AAD domain - any normal user can do that.
I should have said that I am using AAD Basic, so Intune is not involved. I only tried another Global Admin in case there was some limit per account and wanted to be sure that it was not permissions related, in the Azure console I have not set any restrictions on who can join and set the number of devices to unlimited. The existing joined machines were joined by more than one account. If there is a limit then it is very low...?



Try to go on old azure portal (https://manage.windowsazure.com)

select Active directory

select your domain

select configure

Find 'Maximum number of devices per user'