SOLVED

Profile=Default taskbar icon get pinned at first start of Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-1275350%22%20slang%3D%22en-US%22%3EProfile%3DDefault%20taskbar%20icon%20get%20pinned%20at%20first%20start%20of%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1275350%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20install%20the%20new%20Edge%20with%20SCCM%20and%20in%20the%20master_preference%20file%20this%20settings%20are%20defined%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E%22create_all_shortcuts%22%3Afalse%2C%0A%22do_not_create_desktop_shortcut%22%3Atrue%2C%0A%22do_not_create_quick_launch_shortcut%22%3Atrue%2C%0A%22do_not_create_taskbar_shortcut%22%3Atrue%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EAll%20looks%20good%2C%20there%20are%20no%20icon%20in%20the%20taskbar.%3C%2FP%3E%3CP%3EBut%20after%20first%20start%20an%20icon%20geht%20pinned%20with%20this%20target%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E%22C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%20Beta%5CApplication%5Cmsedge.exe%22%20--profile-directory%3DDefault%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EHow%20could%20i%20prevent%20this%20behaviour%3F%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1280019%22%20slang%3D%22en-US%22%3ERe%3A%20Profile%3DDefault%20taskbar%20icon%20get%20pinned%20at%20first%20start%20of%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1280019%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F522208%22%20target%3D%22_blank%22%3E%40pilgi3%3C%2FA%3E%26nbsp%3BReplied%20%3CA%20title%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Fedge-beta-ignores-desktop-icon-setting-in-the-master-preferences%2Fm-p%2F1280016%23M1560%22%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Fedge-beta-ignores-desktop-icon-setting-in-the-master-preferences%2Fm-p%2F1280016%23M1560%22%20target%3D%22_self%22%3Ehere%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)Project%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1320996%22%20slang%3D%22en-US%22%3ERe%3A%20Profile%3DDefault%20taskbar%20icon%20get%20pinned%20at%20first%20start%20of%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1320996%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESame%20with%20the%20new%20version%26nbsp%3B81.0.416.58.%3C%2FP%3E%3CP%3EThe%20install%20of%20Edge%20happens%20through%20the%20SCCM%20OSD%20tasksequence.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1616137%22%20slang%3D%22en-US%22%3ERe%3A%20Profile%3DDefault%20taskbar%20icon%20get%20pinned%20at%20first%20start%20of%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1616137%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20behavior%20is%20fixed%20with%20version%2084%20it%20seems.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

We install the new Edge with SCCM and in the master_preference file this settings are defined

 

"create_all_shortcuts":false,
"do_not_create_desktop_shortcut":true,
"do_not_create_quick_launch_shortcut":true,
"do_not_create_taskbar_shortcut":true

 

All looks good, there is no icon in the taskbar.

But after first start an icon geht pinned with this target

 

"C:\Program Files (x86)\Microsoft\Edge Beta\Application\msedge.exe" --profile-directory=Default

 

How could i prevent this behaviour?

Thanks!

 

3 Replies

@pilgi3 Replied here.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted 

Same with the new version 81.0.416.58.

The install of Edge happens through the SCCM OSD tasksequence.

best response confirmed by pilgi3 (Contributor)
Solution

This behavior is fixed with version 84 it seems.