MS Edge 79.0.309.65 on Windows 7 - Internet Explorer mode: unsupported

Occasional Contributor

Running Windows 7 Professional x64. All updates from Microsoft Update installed, optional or not. 

As per advice on this page, I made sure both KB4507437 and KB4511872 updates are installed (they already have been), I also manually installed the latest security rollup for IE 11.

And yet, edge://compat/iediagnostic still shows "Internet Explorer mode: unsupported", and shows me the "Windows Update" button. Group policies seem to have been applied, "Group policy settings" are "on" according to the diagnostic page.


5 Replies


Do you have all windows 7 updates installed? I had windows 7 problem with IE mode not working. But that was solved after windows monthly rollup upadate (don't remember which month update that was)

See first paragraph...
Yes, everything is installed, Windows doesn't find any more updates.
EDIT: I'd like to mention some more details:
- In terms of Windows 7 monthly rollups, I have installed not just the older, linked KB4507437 from July 16, 2019, but also the latest monthly rollup from January 14, 2020 (KB4534310)
- Yes, the computer has been restarted (several times) after installing all the updates.
- Despite the IE mode showing as "unsupported", when I try to open a site present in the Enterprise Mode Site List, a separate Internet Explorer window with that page opens. So it seems it somewhat works, but I expected the page to open in IE mode, internally within Edge, just like another tab. Is this expected behaviour for Windows 7?
best response confirmed by kamild1996 (Occasional Contributor)



It opens in Edge tab for me, not separate internet explorer. What policies do you have?
I have these visible under edge://policy 



The only policy present in edge://policy is "InternetExplorerIntegrationLevel", which is set to "2" in my case.
I see the difference between your and my setting, let me try changing that...


So, that was it... I misconfigured it, I changed the policy to a different setting so it now shows "1" in edge://policy and now it works, thank you :)

It works, even though edge://compat/iediagnostic still shows "unsupported"... Sounds like a bug, doesn't it? This is what ultimately didn't make me consider my group policy might have been set the wrong way.