Old Edge works but new edge does not

Brass Contributor

Hello, I am attempting to figure out why new edge will not work when I download it.  When I download it and open it, I get error loading page.  When I uninstall the new edge and open the old edge, no error.  Any points would help out greatly.  Thank you.  

13 Replies


Hi there, you are welcome to the Microsoft Edge Insider Community Hub!

Can you please give more information about your problem like what happens and when it happens. It will be also good to see if you add screenshots about the problem.


I would also recommend you to send feedback about this bug through the in-app feedback tool in Microsoft Edge (Alt+Shift+I) with the diagnostics attached to help the Microsoft Edge dev team to resolve your issue as soon as possible.


I can not send a feedback because of this error.


That is right after a new install of the new Edge.  


Please follow the steps as shown in the picture below to open and send feedback from Microsoft Edge Chromium.

2020-06-30 (6).png


Also tagging @Deleted and @MissyQ, our Community Managers to further look into this issue. 



I did do that and nothing pops up.  I tried it on my PC and a pop window came up.  I can not even access edge://settings.  


Was your windows popup like this one:

2020-08-18 (4).png

If yes, please send feedback from there by typing your issue in the big text box given.


I may recommend you to uninstall the new Edge and download the new Edge from this webpage and then install it. Please find the newest Edge version (on the first page, no need to go to later pages) by searching for by your CPU architecture and the stable channel. 


Let's hope for this issue to get fixed as soon as possible.


Installed the latest version and still no luck.  


Please provide some photo's of what you see.

regards, Henno

I did already in the thread.  @Henno_Keers 

@PKeller80  If you use Symantec Endpoint Protection and are on a version prior to 14.2.x check out RenderCodeIntegrity.  https://docs.microsoft.com/en-us/DeployEdge/microsoft-edge-policies#renderercodeintegrityenabled 

@PKeller80 Thanks for reaching out! As @DugTan mentioned, it seems like the root is that one of your software programs is out of date. (It could be Symantec, it could be something else.)


We appreciate your troubleshooting work, @TheShaunSaw. Just a friendly reminder for everyone that Microsoft asks that you only download its products directly from us and not a third-party site, which ensures your security. You can download our three preview channels here, and/or the stable version of MSFT Edge here


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge


Microsoft Update Catlog is Microsoft's own website but as you told right right now, I will take care in the future that if anything happens, I will only recommend users to download from the it from the official Microsoft Edge website. 

@TheShaunSaw You're right, my apologies for the confusion with my original message! But yes, those other two download pages are generally the best sources. Thanks :)


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge