NTP has reverted locale

%3CLINGO-SUB%20id%3D%22lingo-sub-974488%22%20slang%3D%22en-US%22%3ENTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974488%22%20slang%3D%22en-US%22%3E%3CP%3EUp%20until%20yesterday%2C%20my%20NTP%20has%20been%20set%20to%20de-DE%2C%20which%20is%20my%20Windows%20locale.%20Edge%20is%20also%20set%20to%20German.%20However%2C%20the%20NTP%20is%20now%20suddenly%20set%20to%20en-US%2C%20with%20no%20way%20to%20set%20it%20back.%20Or%20is%20there%3F%20Does%20somebody%20know%20something%20that%20could%20work%20here%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOn%20a%20possibly%20related%20note%2C%20Application%20Guard%20also%20always%20starts%20in%20en-US%2C%20although%20it%20does%20start%20in%20de-DE%20from%20another%20Windows%20user%20profile%20that%20I%20have.%20Could%20these%20issues%20be%20related%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974822%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974822%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418331%22%20target%3D%22_blank%22%3E%40adrianghc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EWhich%20Edge%20insider%20channel%20and%20version%20are%20you%20using%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethere%20are%203%20possible%20things%20that%20might%20effect%20it%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eone%20is%20here%3A%20edge%3A%2F%2Fsettings%2Flanguages%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eand%20the%20other%20is%20on%20msn.com%3C%2FP%3E%3CP%3Eclick%20on%20the%20little%20gear%20icon%20on%20the%20top-right%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20299px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F154024iAA8B6F721C73640F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-11-02%20015828.png%22%20title%3D%22Annotation%202019-11-02%20015828.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethe%203rd%20one%20can%20be%20when%20the%20user%20is%20using%20VPN%2Fproxy%20etc%20that%20changes%20IP%20address%20and%20so%20the%20NTP%20could%20detect%20location%20from%20your%20IP.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974823%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974823%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThe%20locale%20is%20set%20to%20German%20both%20on%20MSN.com%20and%20inside%20Edge.%20I%20have%20no%20VPN%20or%20Proxy%20active%20right%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974841%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974841%22%20slang%3D%22en-US%22%3ESounds%20like%20a%20bug%20then%2C%3CBR%20%2F%3EWhich%20Edge%20insider%20channel%20and%20version%20is%20it%20happening%20on%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974842%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974842%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThe%20latest%20Edge%20Dev.%20Creating%20a%20new%20profile%20does%20not%20solve%20it.%20Reinstalling%20Edge%20did%2C%20however%2C%20but%20not%20now%20I%20have%20the%20problem%20that%20the%20NTP%20shows%20only%20the%20default%20mountains%20and%20no%20Bing%20picture%20(even%20though%20it%20is%20in%20fact%20the%20new%20NTP%2C%20with%20dark%20mode%20and%20everything).%3C%2FP%3E%3CP%3EReinstalling%20Edge%20also%20fixed%20the%20language%20issue%20in%20Application%20Guard.%20Curiously%2C%20the%20NTP%20in%20Application%20Guard%20does%20show%20a%20Bing%20picture.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974865%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974865%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418331%22%20target%3D%22_blank%22%3E%40adrianghc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYeah%20sometimes%20I%20get%20that%20too%3C%2FP%3E%3CP%3Etry%20the%20custom%20layout%20with%20these%20options%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20359px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F154025iCFEF81A200437D3E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-11-02%20021251.png%22%20title%3D%22Annotation%202019-11-02%20021251.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974866%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974866%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BNo%20dice.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20you%20say%20you%20get%20that%20too%20sometimes%2C%20do%20you%20mean%20that%20after%20some%20time%20it%20fixes%20itself%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974868%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974868%22%20slang%3D%22en-US%22%3EYup%2C%20it%20eventually%20comes%20to%20its%20senses%20and%20shows%20me%20the%20up-to-date%20Bing%20pic%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974869%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974869%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BWell%2C%20in%20that%20case%20I%20guess%20I'll%20just%20wait%20a%20bit.%20How%20long%20did%20it%20usually%20take%20for%20you%20in%20the%20past%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974872%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974872%22%20slang%3D%22en-US%22%3EUsually%20after%20a%20computer%20restart%20or%20a%20couple%20of%20browser%20restarts%20i%20guess%2C%20really%20not%20sure%20sorry%3CBR%20%2F%3E%3CBR%20%2F%3Ewhen%20you%20uninstalled%20Edge%20dev%2C%20did%20you%20choose%20to%20remove%20all%20user%20data%20as%20well%3F%20i%20think%20that%20option%20comes%20as%20a%20checkbox%20during%20uninstall%20process%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974875%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974875%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BYes%2C%20I%20did%2C%20but%20I%20had%20a%20copy%20of%20the%20user%20profile%20folder%20(and%20only%20the%20profile%2C%20nothing%20else)%20that%20I%20copied%20back%20in%20afterwards%20(the%20NTP%20was%20broken%20both%20before%20and%20after%20doing%20this).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974885%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974885%22%20slang%3D%22en-US%22%3EWell%20i%20believe%20you've%20tried%20everything%20possible%20for%20now%3CBR%20%2F%3Eit's%20a%20bug%20worth%20reporting%3CBR%20%2F%3Ehopefully%20soon%20it%20will%20get%20back%20to%20normal%20for%20you%20%3Acrossed_fingers%3A%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974888%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974888%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThank%20you%20for%20your%20help!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-974905%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-974905%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418331%22%20target%3D%22_blank%22%3E%40adrianghc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnytime!%3C%2FP%3E%3CP%3Eat%20least%20we%20tried%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-976075%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-976075%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BAnd%20I%20got%20the%20Bing%20background%20again.%20%5E%5E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-976082%22%20slang%3D%22en-US%22%3ERe%3A%20NTP%20has%20reverted%20locale%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-976082%22%20slang%3D%22en-US%22%3EGreat%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Highlighted
Frequent Contributor

Up until yesterday, my NTP has been set to de-DE, which is my Windows locale. Edge is also set to German. However, the NTP is now suddenly set to en-US, with no way to set it back. Or is there? Does somebody know something that could work here?

 

On a possibly related note, Application Guard also always starts in en-US, although it does start in de-DE from another Windows user profile that I have. Could these issues be related?

15 Replies
Highlighted

@adrianghc 

Hi,

Which Edge insider channel and version are you using?

 

there are 3 possible things that might effect it,

 

one is here: edge://settings/languages

 

and the other is on msn.com

click on the little gear icon on the top-right 

 

Annotation 2019-11-02 015828.png

 

the 3rd one can be when the user is using VPN/proxy etc that changes IP address and so the NTP could detect location from your IP.

Highlighted

@HotCakeX The locale is set to German both on MSN.com and inside Edge. I have no VPN or Proxy active right now.

Highlighted
Sounds like a bug then,
Which Edge insider channel and version is it happening on?
Highlighted

@HotCakeX The latest Edge Dev. Creating a new profile does not solve it. Reinstalling Edge did, however, but not now I have the problem that the NTP shows only the default mountains and no Bing picture (even though it is in fact the new NTP, with dark mode and everything).

Reinstalling Edge also fixed the language issue in Application Guard. Curiously, the NTP in Application Guard does show a Bing picture.

Highlighted

@adrianghc 

Yeah sometimes I get that too

try the custom layout with these options

 

Annotation 2019-11-02 021251.png

 

 

Highlighted

@HotCakeX No dice.

 

When you say you get that too sometimes, do you mean that after some time it fixes itself?

Highlighted
Yup, it eventually comes to its senses and shows me the up-to-date Bing pic
Highlighted

@HotCakeX Well, in that case I guess I'll just wait a bit. How long did it usually take for you in the past?

Highlighted
Usually after a computer restart or a couple of browser restarts i guess, really not sure sorry

when you uninstalled Edge dev, did you choose to remove all user data as well? i think that option comes as a checkbox during uninstall process
Highlighted

@HotCakeX Yes, I did, but I had a copy of the user profile folder (and only the profile, nothing else) that I copied back in afterwards (the NTP was broken both before and after doing this).

Highlighted
Well i believe you've tried everything possible for now
it's a bug worth reporting
hopefully soon it will get back to normal for you :crossed_fingers:
Highlighted

@HotCakeX Thank you for your help!

Highlighted

@adrianghc 

Anytime!

at least we tried :)

Highlighted

@HotCakeX And I got the Bing background again. ^^

Highlighted
Great :)