How to set the ozone platform hint flag

Copper Contributor

I have a laptop with a high-res screen, running Ubuntu 22.04 and fractional scaling enabled at 175%. This works nicely for Wayland applications, but XWayland/Xorg applications become blurry.


In chrome and chromium I can make the browser use Wayland by setting the flag chrome://flags/#ozone-platform-hint to "auto", but this flag seems to be missing in Edge.


I noticed I can launch successfully edge from the terminal with --ozone-platform-hint=auto, and I played a bit with updating the .desktop file Exec command's to include this, but this would break PWA's I have installed such that they no longer appear as dedicated applications.


Any one know any good work-arounds? And if anyone from the Edge product/development team reads these discussions then please consider this a feature request to add the missing flag :D

0 Replies