BUG: Can't save passwords for 'localhost'

Copper Contributor

The browser won't allow to save passwords for websites running on localhost (e.g. as a developer) due to failed syntax check; it's expecting a valid domain name or IP address and suggesting to append ".com" to "localhost".  Not a security thing, because I can save passwords for just fine (since it's a valid IP). This is clearly a bug. The syntax checker must allow "localhost" as an exception for a proper domain name (which it is!)

1 Reply
This bug prevents you from manually adding or editing passwords saved from localhost. I was able to work-around this bug by turning on "Offer to save passwords" in Settings > Profiles > Passwords > ... menu > Password Settings. I'd previously turned this off.