Broken Websites

Highlighted
Regular Contributor

Let's dedicate this thread to websites, which exhibit unusual behavior in Edge Insider. They either don't open or work as expected, or cause high CPU and/or GPU load when in focus. 

 

One can check current hardware load in Settings-More Tools-Browser Task Manager, make a screenshot, and post it here. Before reporting the issue, try installing an Add Blocker extension like uBlock Origin, reload the webpage, and see if the Tab hardware load drops shortly. On older PCs and laptops, fans usually wind up with loads, so you feel it fast.

35 Replies
Highlighted
Just noticed I do not work some sites.
Found only two.
https://www.weblancer.net
https://thecommunity.ru
Spin the download spiner and the tab hangs without answering.
In other browsers opens without problems.
Highlighted

@HD321kbps 

 

Thanks for the examples. I just check these pages, they load into Edge Dev 172 64-bit, but as many East European sites give high CPU and GPU processes load. It definitely needs devs investigation, unless of course its a "policy". May be some Edge Telemetry scripts don't make friends with European sites? :) They open in Chrome with near 0% CPU load. Fixing Edge handling of one of such sites may fix its handling of most of them.

 

HighCPU on RU.jpg

Highlighted

@sambul95 

Stopped working in the last 2-3 builds Canary

Highlighted

@Deleted Confirming the same behavior in 175.  Random sites won't load and tab says "Not Responding". All sites work in old Edge and Chrome.


@HD321kbps wrote:
Just noticed I do not work some sites.
Found only two.
https://www.weblancer.net
https://thecommunity.ru
Spin the download spiner and the tab hangs without answering.
In other browsers opens without problems.

In Version 76.0.176.0 fixed

Highlighted

@HD321kbps 

 

Can you post Browser Task Manager screenshot on that site in v176 (wait for it to populate fields)? Was high CPU & GPU processes load fixed too?

Highlighted
Highlighted

@sambul95 
The load remained high.
CPU tab up to 125 when loading and scrolling up to 25.


Highlighted

@sambul95 Hi, I currently cannot confirm your high CPU/GPU problem here in germany on my two Windows 10 build 18362.145 devices (desktop [i7-6850k / GTX 1060] & notebook [i5-7200U / HD620]).

I use Edge Dev and Canary without any extension. If I load websites, I see for a short time spikes over 25 % and then under 6%.

 

Are you using a different anti virus program than Windows Defender?

Highlighted

 

The load remained high.
CPU tab up to 125 when loading and scrolling up to 25.



Tested in more detail. The load is not very high comparable with other browsers.
https://www.dropbox.com/s/xrfnenkgojevt9t/Video_2019-06-01_143528.wmv?dl=0

Highlighted

@HD321kbps 

 

Thanks for the great video. The load is high for you at site content sent to translator. But I was not talking about it, its a separate issue. I mean high CPU and GPU load: 6 to 30% at simply idling the site without scrolling the page. Before we observed similar high periodic load sparks on ANY site opened with Edge. Pls read this thread: Browser and GPU process are much higher compared to Brave.

 

That issue was fixed due to community feedback. Now we observe similar issue on most European, and particularly East Europe sites. Possibly due to common scripts used not frequent on North American sites. Absolute load values depend on CPU model, so folks with new PCs may  think its OK, but for older PCs its way too high sparks causing excessive fan load and battery use. Chrome Task Manager shows near 0% CPU and GPU load on same sites. When posting load screenshots, its important to add your hardware info (CPU, GPU, RAM).

Highlighted

Google Chrome is becoming more and more IE6 ("works best with....") 

 

Highlighted

@Rixster 

 

Here is a french website BlaBlaCar that represents a typical problem for Edge Chromium. The browser CPU and GPU load is constantly high indefinitely long on many European websites, while it stays mostly 0% in Google Chrome regardless of PC age and CPU power.

 

BrokenSites2.jpg

Highlighted

@Elliot Kirk 

I have opened a bug that references this thread.  Whenever you find a website that isn't working with the Insider builds, just add it to the bottom of this thread, with the build that you have tried it on and the symptoms that you are seeing. 

What is the bug number? I need to reference it in talks with Edge Support. 

 

Here is another example of hugely popular website Edge Chromium Dev 179 and all other versions show with indefinitely long high CPU and GPU load: 4pda     The load seems to be caused by the same popular script frequently used on European sites. Chrome shows it at 0% load. I don't see any progress on this matter at all.

Highlighted

@sambul95 

Retecool.com, H3 and H2 headers look compressed
retecool.jpg

Highlighted

Hi @sambul95, we are still unable to repro these on our side, but we aren't giving up yet!  We are trying to figure out if this behavior is in the Chromium code or in one of our changes.  To understand this better it is very helpful to understand if you are seeing this same CPU load in the Chromium daily builds as well as Microsoft Edge Canary and Dev channels.  It is possible that Chrome does something extra that Chromium doesn't do, but we cannot investigate more fully until we are able to reproduce this high CPU load.  That said I was able to see a high CPU load from the link that @HD321kbps supplied (thecommunity.ru).  I don't see a difference between Chromium and today's Dev channel, though.  In this case it is likely that the site is doing something rather than a bug with the browser.  For the 4pda and weblancer sites, both the CPU and GPU processes drop to 0 very quickly and then just pop-up every couple of seconds to check on various threads.  Feel free to reach out to me directly again and we can continue looking at this issue.

 

Thanks,

Elliot