Cannot Add services to Free Trial

Copper Contributor

Started a Free Trial subscription and every time I try to add a service, storage account, vnet, etc... I get a Subscription Not found error.

statusCode:NotFound statusMessage:{"error":{"code":"SubscriptionNotFound","message":"Subscription "removed for this post" was not found."}}


Is there something super simple I'm missing?

3 Replies

Hi Matthew,

I have the exact same issue with an Azure subscription that is linked to my MSDN account.

I'm doing one of the labs of the 20-533 course, and the first error I got was when I could not create a Storage Account via Powershell. I then tried to create the Storage Account via the Azure Portal and there I also got the same error.


At the start of the lab, a Storage Account was created just find, and that was around 2.5 hours ago (around noon CET).
I've been waisting more than an hour with this issue now... 

I hope someone from MS can give an answer to what is causing this.




I was able to work around this error by selecting a different region when creating my storage account and virtual network.  I'm guessing the Free subscription isn't available in all selectable regions.

Hi Matthew,
I was able to create a storage account on Monday in the same region where it was failing on Sunday, so I guess something must have been wrong on the azure side...
Good to hear it works again for you too :)
Cheers, Charles