Invalid connection file - Any ideas how to get past this?

Copper Contributor

Hey all,


I've been chipping away at getting a WVD proof of concept going, and I'm at the point where I have a successful deployment, and I think I am ALMOST all the way there. I have a demo tenant that is running AD DS, with AD Connect syncing my AD DS users to Azure AD. I created my WVD tenant, and then deployed my pool through the market place, and joined my session hosts to the domain.  My test user is able to log in through the Remote Desktop app and it pulls down the default Session Desktop, but when I try and launch it I received this error (Invalid Connection File). I navigate to the actual RDP file, and tried to launch from there - I get prompts to log in, and my UPN gets past them but then it errors out again. I'm not sure how to get past this point - anyone have any ideas?image.png



14 Replies

@rbergertd This looks like classic RDP issues.  On the session host, I would try to delete the user profile if it even created one and try logging in again.  You may want to log into RDS powershell as well and run get-rdstenant to see if your tenant is fully provisioned.

One thing to note is that, the HTML5 portal does work. So, I've got something! I tried to remove the feed, and re-add it, but no dice. I thought it may of been related to the autodiscovery via e-mail, as I do not have e-mail configured in my test tenant. But, since the web portal works I do not believe it's that.

@rbergertd Yeah.  Since this is so new, it's hard to troubleshoot and I'm just going by past things I know.  Question, I had issues earlier where I could not log into the HTML5 until I made the user a tenant creator in Azure AD for WVD.  But the RDS app worked fine.  Quirky but it's only day 2!

@stevenzelenko Thanks for the rec. I did check the tenant multiple times and I *think* everything is provisioned. Does this look okay to you? It's so odd, but I'm happy to end the night on a win with at least figuring out HTML5 is working. :)



@rbergertd That is how mine looks.  The HTML5 integration is fantastic.  I would check your WVD application users in Azure AD and maybe put your test user as a tenant creator.  I had to do that for all my synced test users to get it to work flawlessly.  It doesn't sound right but it works.  And I got MFA working too.  Cool stuff this.



@stevenzelenko Yea, I had tried that - no dice unfortunately. I still get that file error. Ugh! 

@rbergertd Please try to remove the feed you added using the ellipsis next to tenant information  and add the feed again?

@Eva SeydlHi Eva I did try this, no dice. I am assuming you were talking about removing the feed from the Remote Desktop application, which I did 'unsubscribe' and then 'resubscribe' to it - to pull my resources all over again. One of the weird things, is my icon is blank for the RDP within the list of resources. As I said above, I tried to manually browse to the location where the RDP file lives and launch it from there - where I am greeted with some different errors... but HTML5 is still working. Sort of puzzled. :) 



@stevenzelenko Just a little more info, I just checked the status of my RDS Session host and it all looks good. I am convinced this has gotta be something on the client end. I tried forcefully removing the .RDP files that the client creates in AppData and letting it recreate them, but it's still giving me the same error so who knows. The thing that is a bummer, is what I am working on, I really need the native RDP experience and don't want to even start testing it with the HTML5 piece. :( 



@rbergertd : Can you try to refresh the feed? Use the 3 buttons again and click details. At the bottom of the page you will find an update now button. See if this mitigates the issue.


If you are still not able to connect please share feedback with using extending the 3dots on the top right corner in the app next to settings. You will be redirected to feedback hub. This will help us to get the right information we need for your issue.




@Eva Seydl Eva, this appears to be limited to my workstation Remote Desktop client. Even after total removal and reinstall, I get the error. I built up another VM to test installing the client on and am able to access my resources via the Remote Desktop client installed on the new workstation. So I think at this point I've got a fully functional deployment. Just something wonky with my client install (which I've yet to resolve :)) 

I'm having the same issue now on one of the computers using the latest version Reinstall, and unsubscribe/re-subscribe didn't resolve the problem. Any ideas? 




I also have blank icons, are you using 4k screens perchance?

I can't access the link. I recommend for troubleshooting to open a support ticket through the Azure Portal if this is related to Azure Virtual Desktop