Cannot install per user app on Azure Virtual Desktop

Copper Contributor

Since some application my org uses have been updated to be user install only I'm unable to update them on my pooled Azure Virtual Desktop deployment.

Even trying with administrator account i keep getting the "The System Administrator has set policies to prevent this installation".

Screenshot 2023-04-26 153736.png

Have tried this on a test environment too, with the same result.

No GPO has been deployed to prevent this behaviors. (No turn off Windows Installer, no software restriction, no msi disabled etc..)
To be more specific I'm trying to install some digital signature check application (GOsign, Arubasign) but I get the same result.
I've even tested that on Google Chrome in user mode, getting some custom error message.

Can anyone confirm this behaviour?
Have anyone found a way to make this work?
I've done some research but haven't found any confirm from Microsoft documentation.

2 Replies


Did you try to locate event logs for hints?

Havn't found anything meaningfull, just that the MSI install aborted